Ducati.ms - The Ultimate Ducati Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
85 Posts
Discussion Starter #1 (Edited)
Everyone,

I need help in a major way! I was out riding on my 1995 916 at night and during my journey home I experienced probably the scariest thing I have ever experienced, the loss of headlights.

Here is the information I have to share if it helps.

-The headlights come back on when I jiggle the large connection on the right side which connect the front harness to the main.

-After turning the bike off with the headlights / tach in the non-working situation the fuel pump still turns on when the key is on and the kill switch is turned to the on position.

-The tail lights still work.

-I clean and grease the connector regularly.

-Lastly, I thought the problem was in the front harness so I replaced it with a used harness and I still have the same problem.

Other important information. I did replace my battery a few years back and the jackwagon who installed it didn't put the caps on all the way so I have acid damage. The damage has been present much longer than the electrical issue.

Thanks for taking a second to look at my post. Any advice would be very much appreciated.

David
 

·
Registered
Joined
·
14 Posts
Had a similar problem on my 1098. Was a bad regulator rectifier. Not sure it's the same issue on your 916 though. My lights would go out intermittently along with the dash display.
 

·
Registered
Joined
·
80 Posts
I just had the same problem with my 95 916. After an hour of riding, lost the instrument panel and lights while stopped at a light. \I went to the nearest Canadian tire and picked up a pocket tester to see if the RR was dead. Battery was good and getting a full charge. I decided to ride home. 10 minutes later, everything came back on.

I replaced my RR last year with the same brand I've had running for the last 6 years. Battery was also replaced. Both are in good working condition.
All my connectors seem to be tight.
 
1 - 4 of 4 Posts
Top