Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi guys,

My name is James, i recently purchased an 800Sie from 2003. The previous owner has done some minor work to it, like replacing the indicator lights with LEDs, and I'm geussing this may be the source of the problem...

It seems like none of the lights on the dash work, except for the neutral gear indicator. I'm a complete noob, and this is my first bike, but I'd really like to learn about fixing it and was wondering if anyone knows where I can find info, or help me with some troubleshooting.

Let me know if I need to send pics or any more info!
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks RockAZ, i'll give it a look.

Is it possible that my lights arent working because of the addition of LED indicator lights? If I change those back to original lights should it be fixed? Is that a common problem, the system not being set up for LEDs in the circuit?
 

·
Registered
Joined
·
3,546 Posts
Yes, and its an easy cheap test, but it seems to me the neutral light and kickstand down light should still work as it is not wired into anything else.

Tach/speedo lights come on?

There is a connector from the wiring harness to the back of the dash cluster that has most of the power to the dash lights, wonder if that has come off?
 

·
Registered
Joined
·
3,292 Posts
unplug the indicators and plug some originals in.

i doubt that's the issue. i'm guessing it was sold because the dash is rooted and because it's all ic in there the option is pretty much a new one.
 
1 - 8 of 8 Posts
Top