Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 3 of 3 Posts

·
Premium Member
Joined
·
2 Posts
Discussion Starter #1
Hi Guys,
Went for a spin yesterday and realised the EOBD came on half way threw the spin,
No difference in performance or any other signs of problem on dash etc..

Then when I got back stopped her and tried to start again and noting..:frown2:
Turn the ignition sounds normal fuel pump runs the demobilise light goes off but she wont fire, no turn over what so ever.
Can here a click or two ( relays Not sure ) but I cant remember is that normal or not..
Any one any ideas where to start, I dont use the kill switch only use the key. I check 3 fues under the seat but thats all.

A bit worrying because in a few weeks Im doing a 4000km tour of Europe via the Ducati factory. But better to happen now than then :|

Thanks Guys
 

·
Super Moderator
Joined
·
5,365 Posts
My first thought, given that the EOBD light came on, is failing battery. If you have a volt meter check it out. The ECU needs a certain minimum voltage (I think it's 12.4 V) or it will shut down.

If the light didn't come on, then I'd be looking at the kill switch, side stand switch. Check the major connections and all the fuses.
 

·
Premium Member
Joined
·
2 Posts
Discussion Starter #3
Got it sorted,
checked found out how to check the codes and was 19.2 start solenoid , so checked the fues and was blown changed it and she started and ran fine took her for
a spin and she blew again, traced it down to every time I touched the back break she blew the fuse.
So never break and no more prolems :wink2:, So got a new sensor and she works fine..:grin2:.
 
1 - 3 of 3 Posts
Top