Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2021 HERE!
1 - 1 of 1 Posts

·
Registered
Joined
·
3,642 Posts
Bike: 2004 749 half termi with termi ecu 19k miles
Symptoms:
1.)fan turns on when you switch key to on
2.) bike will start but it sounds like it is running on one cylinder and won't hold idle.
3.) bike ran fine before conking out

There is spark on both cylinders


Back story
I rode it for about 500 miles without a problem after rebuilding it but the starting sequence kept on getting harder and harder every time I go out to ride. before it conked out, the LCD dash acted funny like it was broken and then the fan never turned off after riding (even after 2 hours). I tried bumpstarting but it wont hold idle and smelled very rich and also sounded like it ran on one cylinder. I have replaced plugs since they were black (soot). I also replaced the rectifier but it did not solve the problem.
I had a similar issue a couple years back with my 749. Initially, I had a "HI" voltage reading on the dash. I replaced the R/R unit and problem persisted. Started chasing around the wiring harness looking for problems.

Eventually, my fans would come on when the ignition was turned on (as you describe) and poor running. After poring over every electrical circuit, I determined it was a bad ECU and replaced it with a Microtec. Problem solved.

Not saying your ECU is bad, but the sypmtoms are eerily similar to mine.
 
1 - 1 of 1 Posts
Top