Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
ok so I have 2 CEL lights that I want to turn off.
bought what was said to be the correct cables, and gonna download TuneECU

go to connect the cables to the bike (2007 1098), and they dont plug in...
seems the 3 metal male pins are too wide to fit into the ducati plug

yeah i could open up the plug and grind them down, but i really think i shouldnt have to do that.... something else must be wrong?
do i not have the correct cables or something?

is there another option?
bike has been sitting for WEEKS, over a stupid CEL light (bike runs fine), really pissing me off at this point how doing something so simple has turned into such a PITA






and is this even the right thing that I need? and if so, what setting do i want it at ?!
 

·
Just Visiting Your Planet
Joined
·
10,368 Posts
OBD II to Fiat cable is the correct piece. Looks like your Fiat cable isn't quite right. Sorry, can't help with the VAG-KKL settings for your setup.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
so i took the red thing off the connector on the Ducati, and was able to shove in the OBD converter wire thing.
curious that the ducati only has 2 (two) wires going to that 3 wire diagnostic port (?)

anyways, cant get TuneECU to recognize the bike. so i still got a CEL light that i can not clear...

Dealership says $XXX and a month wait, which is fucking bullshit, tho perfectly expected considering its a Ducati....

any help appreciated ...

bike has a race ECU btw, dunno if that changes anything
 

·
Registered
Joined
·
463 Posts
No connection is 99.9% cable related.

So which cables do you have, any pictures?
 
1 - 4 of 4 Posts
Top