Ducati.ms - The Ultimate Ducati Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
So I have my brand new 696 and the throttle is kind of peculiar.

It seems that there is a bit of play in the throttle, I turn it ever so slightly and nothing, I turn it just a bit more and the rpms jump to 4000rmp.

When I drive it seems very peticular, the throttle seems to be jumpy. Just wondering if this is the way the 696 comes or if I am just a newbie.

Let me know.....
 

·
Registered
Joined
·
25 Posts
There is either an actual issue there, or you are simply adjusting to a new bike, and need to learn how sensitive it is, and how to roll the clutch.

Have your dealer look at it.
 

·
Registered
Joined
·
312 Posts
Sounds like your throttle cable needs to be adjusted. But it also may be just adjusting to the new throttle and clutch.
 

·
Premium Member
Joined
·
2,455 Posts
Turn the throttle with the bike bike off and on the sidestand, while watching the plastic cam on the throttle bodies. Until the cam moves, twisting the throttle has done nothing, so you shouldn't expect a response. If the play is excessive in the cable it is pretty easy to adjust it. You definitely should not have a lag in engine response once the throttle bodies actually start to open. If you do it is a tuning issue, such as a TPS setting error.
 

·
Registered
Joined
·
355 Posts
What you're describing happens a lot with completely stock Ducati's. The fueling from the factory absolutely sucks because it has to meet emissions. Switching to an aftermarket exhaust and ecu should cure that problem.
 
1 - 6 of 6 Posts
Top