Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
Joined
·
503 Posts
Discussion Starter · #1 ·
Hi Guys,

My bike is running very sick.....limped home the last 100 klms today.....the pipes are BLACK...the bike won't idle and gets slightly better under acceleration.

I disconnected the FatDuc...no difference.

Any clues....ECU maybe ?

The warranty runs out in 10 days !

Thanks for your help.

Cheers

Roger:confused:
 

·
Premium Member
Joined
·
1,974 Posts
Check your charging system, voltage regulator and battery. I have had a similar experience, almost 2 months ago and had great difficulties to keep my Sport running. Whenever the bike died, we had to bump-start. A fresh battery worked wonders.

Your issue maybe totally different, but definitely worth checking the electrical bits & pieces. If the voltage is off (low) than the ECU starts behaving erratic.

Good luck and keep us posted.

RonB
 

·
Premium Member
Joined
·
2,456 Posts
Hi Guys,

My bike is running very sick.....limped home the last 100 klms today.....the pipes are BLACK...the bike won't idle and gets slightly better under acceleration.

I disconnected the FatDuc...no difference.

Any clues....ECU maybe ?

The warranty runs out in 10 days !

Thanks for your help.

Cheers

Roger:confused:
How is it when it is cold?

I am guessing lambda sensor or engine temperature sensor. Does the temperture reported by the instruments seem correct-ish?

Anyway, I would be taking it to the shop if possible.
 

·
Registered
Joined
·
503 Posts
Discussion Starter · #4 ·
The temps seemed normal...it was raining and cold today :(

The battery seemed to be spinning the starter with normal performance.

Hmmm...just tried to start it cold....same as hot.

I used a tank of juice in about 140 klms today......spluttering down the highway at about 60-70 MPH
 

·
Registered
Joined
·
2,822 Posts
Yeah, bad temp sensor is frequently the culprit when the bike becomes horribly rich. It sees the bike as being cold all the time and so the ECU keeps giving it the mixture it would need to start when stone cold.
 

·
Registered
Joined
·
188 Posts
Hi Guys,

The warranty runs out in 10 days !
put off the fatduc and RUN to the dealer! they should check everything and asume any wrong part (sensor, ecu...). maybe it's a silly thing but maybe it's 1.xxx $ issue and your warranty should cope with it!

no sense to start testing yourself and letting the warranty go!
 

·
Registered
Joined
·
503 Posts
Discussion Starter · #8 ·
GT back to stock

So it's tow truck time tomorrow...tank, seat & exhaust all back to standard. I can't imagine them having any issues with the suspension.....I will let you know the outcome.

Thanks guys.....

Cheers

Roger
 

·
Registered
Joined
·
503 Posts
Discussion Starter · #9 ·
Update

Hi Guys,

Fouled spark plugs....caused by moisture getting into the throttle position sensor....and the TPS telling the ECU to juice it up a bit fellas!

The dealer has put in a work authority to DUC to request they cover the cost....still waiting to find out who pays .

So....no big deal either way.

Cheers

Roger
 

·
Registered
Joined
·
503 Posts
Discussion Starter · #11 ·
Ducati paid

Hi Guys,

I got great service from Brisbane Motorcycles today.....they got it through under warranty....so I got the fluids changed by them to say thanks. Track day 6th July :D

I love happy endings.....
 

·
Registered
Joined
·
2,352 Posts
Hi Guys,

I got great service from Brisbane Motorcycles today.....they got it through under warranty....so I got the fluids changed by them to say thanks. Track day 6th July :D

I love happy endings.....
Glad to hear that, Roger!

BTW: Have you asked them about the price for clip-ons?
 

·
Registered
Joined
·
503 Posts
Discussion Starter · #13 ·
BTW: Have you asked them about the price for clip-ons?

Nah....I have been a bit busy with end of financial year stuff and I visit the painter tomorrow.

http://www.luckycaleb.com

I think I am going to go with just black with silver stripes same style logo as on the tank now and a desmo across the back of the solo seat cowl. He hand paints the logos they are not stickers.....well that's the plan at this stage. :think:

Cheers

Roger
 

·
Registered
Joined
·
503 Posts
Discussion Starter · #15 ·
lol...just bought a new camera the images are too big to load to MS....and I have been too busy to talk to someone to talk me through how to get them out there.... the bike is very nice to ride now...and soon will look the goods.

Cheers ;)
 
1 - 15 of 15 Posts
Top