Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 20 of 29 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I bought an instrument cluster off a 06' SS and it does not allow me to turn my bike on. I tried using my older broken cluster and the bike fired up... I opened both casings the the boards/components look different, yet they use the same plug. Is there an after market instrument cluster for the SS that will work or any way to get the new cluster to work?

Thanks!
 

·
Premium Member
Joined
·
184 Posts
Key, instruments, ignition and computer are all coded to work together. Part of anti theft system. If your broken cluster has a mechanical problem, you may be able to take the electronics out of your old one and put them in the new one? If not you will need a complete set or an aftermarket computer to use with the new gauge.

Mike
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #3 ·
What aftermarket computers are available? aftermarket instruments? Can I use an aftermarket instrument with the current OEM computer?
 

·
Registered
Joined
·
272 Posts
try this:
At least three keys (included the RED key) are necessary to program the immobilizer up to max. 8 keys (included the RED key).
Programming the immobilizer
If one or more parts of the immobilizer are replaced, such as black keys, decoder or engine control unit, system must be reprogrammed. Proceed as follows:
-

ensure that battery poles are correctly connected and the battery is in perfect operating conditions
-

take the red key and the black ones
-

insert the red key (3) in the ignition switch (4)
-

turn the key to ON so to switch on the instrument panel. The multifunction display will show the number of inserted keys (here "1") and a countdown starting from 30. Important: ensure that the ignition switch was to OFF for at least thirty seconds before performing the above
-

ensure that countdown has started and turn the key to OFF before it reaches zero (about three seconds)
-

remove the red key, insert a black key (5) and set the switch to ON within the next 15 seconds (display shows the number of keys inserted, in this instance 2, with the countdown from 30 to 0 at the side)
-

ensure that countdown has started and turn the key to OFF before it reaches zero
-

within 15 seconds: remove the black key, insert the other black key (5) and turn it to ON.
-

The multifunction display will show the number of inserted keys (here "3") and a countdown starting from 30.
-

ensure that countdown has started and turn the key to OFF before it reaches zero
-

remove the black key, insert the red key and set the switch to ON within the next 15 seconds (display shows the number of keys inserted, in this instance 4, with the countdown from 30 to 0 at the side)
-

ensure that the countdown has begun and set the key to OFF before it reaches zero. The LED (1) on the instrument panel will flash to indicate successful programming.

Now two black keys and the decoder inside the instrument panel are successfully programmed. Continue as follows:

-

turn the red key to ON within 15 seconds;
-

leave the key positioned to ON for 5 to 15 seconds (not less than 5 and not more than 15 seconds) to allow data transfer from the decoder to the engine control unit and then turn the key to OFF
-

allow 10 seconds before turning the key to ON again.

Now the programming procedure is over. Immobilizer programming is completed. The above procedure must be fully complied with even though just a part of the immobilizer system needs to be programmed. Partial programming is not allowed! When finished, ensure that the engine starts if programmed black keys are used.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #7 ·
So do I need the red key matching the new cluster? I have the red key matching the bike and the broken cluster.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #9 ·
So I am still having problems with this, I am not getting a number on the key and the cluster keeps flashing the maintenance words on the cluster along with a lighting the engine light... however the old cluster works fine. The guy at the dealer said I could start it with the red key, but have not tried that yet.

I did follow all the directions... sigh, any other tricks?
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #10 ·
I cleared the maintenance message based on previous forum posts... I can't get the number of keys to show still, I tried doing this several times and it does not seem to work. Is there something missing in the steps?? Maye I have to hold on to a button on the cluster??

Thanks!
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #11 ·
Can anyone still help me out on this? I can't get the cluster re-programmed yet. I did namange to get rid of the maintenance message.
 

·
Registered
Joined
·
14 Posts
Can anyone still help me out on this? I can't get the cluster re-programmed yet. I did namange to get rid of the maintenance message.
Unfortunately if clockset you have obtained is used it will not work with your cpu/keys as it will be coded to the original bikes cpu/red key.

The only way it will work on your bike is if you get the keys and cpu from the other bike.

you can code a NEW set of clocks to your cpu/keys but not secondhand ones
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #14 ·
Is there an aftermarket cluster that I can use then? My broken instrument works... maybe i just need the casing for the glasses, and the one I have is not compatible since they seem to be different electronics.
 

·
Registered
Joined
·
6 Posts
I have the excact same problem! I got a "new" instrument, and i can´t get it to work either. What i don´t understand is, why my old instrument dosn´t show the number off keys and the count down from 30 to 1, when i use my red key?
Isn´t there a way to get around this stupid system?
 

·
Registered
Joined
·
3 Posts
Me also. Just bought an '04 749. Came with red key. Runs great no problems using red key. bought two new black keys and tried following the programming instructions. Never get the key count or the countdown from 30. Code symbol just disappears and the red led flashes three times indicating the bike is ready to start... go figure...
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #17 ·
I called a dealer selling a used cluster online, they said it has to be programmed and hooked into their computer to synch the whole system. Another dealer told me I should be able to start it with the red key, butI have had no luck with that. I will be dropping the bike off (maybe take it there with the broken speedo and drop the new speedo for them to change). Also I noticed that the 07' cluster that I bought is a bit different from the 06'.

If anyone does manage to re-program the cluster please DO let me know!
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #20 ·
I am riding the bike with the old cluster... hoping to bring the bike to the mechanic to change the cluster by the end of the month. They said it should not be more than an hour ($100). The dealer should have the tools to resynch the new cluster to the keys and ecu.
 
1 - 20 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top