Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hey guys. Just need some help here. I have a 2007 1098 and took it for a spin on saturday. I passed my buddy doing 166 km/h going uphill. After that I lost throttle response. The max my bike would go around was 90 km/h. I had the throttle twisted the whole way and it wouldn't go any faster. On the way down, it felt like my bike was in neutral when I tried to let off the throttle to use my engine brakes, so I just had to brake hard. My rpm's came down very slowly after I let off the throttle. Some times I was hard on the throttle and suddenly it would grab and take off. I had my engine check light come on as well when this happened. Luckily my passenger stayed on. My bike is at the dealer now, but they say there is nothing wrong. I've been riding for a while now and I know that there is something wrong. Could it be the throttle cable?
 

·
Registered
Joined
·
447 Posts
Was your buddy on the new R1? If so he might have pushed the "EMP" button on his left hand controls.


:)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Has the dealer done the voltage regulator recall yet?

I was on a long ride just breaking my bike in when my voltage regulator failed, and prior to it actually giving up completely the bike felt a lot like what you're describing.
Yes. the dealer has already done the voltage regulator recall.
 

·
Registered
Joined
·
956 Posts
1 - 8 of 8 Posts
Top