Ducati.ms - The Ultimate Ducati Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
So after a couple of years being hidden away due to lack of funds to fix the bike, time is coming for me to to just that.

So I had her out last weekend, tried to turn her over minus plugs (more for oil circulation) and I had nothing, the starter relay I can hear clicking, but the starter itself not turning. I’ve tried a gentle persuasion, but still nothing. Would putting the bike into gear and rocking it back and forth work?

I’ve tried all the usual bits (battery, lights dimming etc...) just wondering if there’s anything else I could do short of taking it out? I’ve not tried the direct battery to starter yet, so that’s another one for me to do.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
3,593 Posts
Is the battery brand new?

check oil level and make sure it is not over filled, gas in the cases.

if you hear the click the bike is trying but a low /weak/bad battery will not allow it. Make sure it is the starter relay (gold colored bit the starter cables attach to) is whats clicking by putting a finger on it when you hit the start button. If it is not clicking then look at the small plug that plugs into it. This is whats attached to the start button so hold the start button down (key on) and wiggle the connector plugged into the starter.

pull the plugs and see if you can turn the motor over (key off) by rotating the rear wheel in 6th gear. If not you have a bigger issue, if yes back to starter issues.

The starter relay is pretty reliable so start by jumping a connection to bypass the starter relay, this is just to test the relay. It is possible the starter is bad (oil seal failure most likely) but It is rare so take the starter cap off only if nothing else turns up.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
Happy to report that the starter is indeed fine, I’d disconnected the starter on strip down back last year when I’d planned on taking the cylinder head off looking for a mysterious oil leak.

Re-connected the starter, and turned over first time (no plugs or exhaust on atm) oil pressure rose and light extinguished. Little baby steps atm, will have her running soon enough


Sent from my iPhone using Tapatalk
 
1 - 4 of 4 Posts
Top