Ducati.ms - The Ultimate Ducati Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I was parked at a pals last week and the same old prob occurred, its a 2003 st4s, I was parked with the bike's back to some horizontal rain. I came out and it wouldnt start, same old same old with the immobiliser getting wet, after some serious wd40 spraying it sprang to life.

Parked it up for a week and the battery is dead, seems to have a drain, wont start and no immobiliser light.

i checked out the wiring today. There was no Immobiliser light on due to the immobiliser ECU not earthing it. Could this be because it hasnt had a signal from the key via the ring aerial around the ignition barrel?? I checked the resistance of the aerial and it was sitting at 16 ohms, not sure what the figure should be but that looked at bit high to me. Ive checked all the other connections to the Immob ECU and all the voltages look ok. Tried the red key and still nothing, turns over fine but wont fire.

Immobiliser and ecu replacements have been mentioned by my not too helpful local duc dealership.

Please help!!!!!

Mark
 

·
Registered
Joined
·
37 Posts
Mark- I know very little about ducs but I do know about chemistry. WD-40 is a great product for helping to removing moisture but it is not what you should be using on electronics. WD-40 has silica (along with a bunch of other stuff) and silica is not a conductor. I would start by getting the WD off the parts now. I do not know what is available to you in the UK but clean the parts using chemicals that will not melt the plastic or rubber protective covers. Check with your nearest computer store or auto parts. Most of the really good chemistry will mess up your paint so be careful and remember anything that will penetrate to clean will also penetrate the plastic covers on your duc and you will never get it out. If water or moisture is a problem at a connection, dielectric gel can be used, but again be careful the gels can be messy and can add to the ohms of resistance, there are different grades of gel.
Why not use WD-40 on electrical parts especially delicate parts? WD-40 would be fine to use in a perfect world with no environmental crap in the air. What happens is WD mixes with all the stuff floating in the air and will create a witches brew that likes to eat small electrical connections.
To dry parts that are “sealed” place them in a container of rice or you can get gel packs from your local computer store. This can take some time.
Best of luck-frank
 
1 - 2 of 2 Posts
Top