Ducati.ms - The Ultimate Ducati Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 07 st3 and am having an alarm/electical trouble. My battery died over the winter so i replaced it and now when i turn the key on it just beeps. The small running lights on the side come on, but nothing from the instrument cluster..no tach...no gauges...nothing..It has a factory ducati alarm on it and when the key is in the "on" position the alarm box just beeps but doesnt go off. any input would be greatly appreiciated.
 

·
Registered
Joined
·
3,883 Posts
This will sound weird: Is the battery installed correctly?? The newer "small" batteries get installed with the label side in. + is always towards the front of the m/c. A lot of people do install them in reverse-polarity connected by mistake.

This blows the 40A fuse (next to the batt.) in an attempt to protect the RR. Many people get lucky, put in a new 40A fuse, put it in properly, and off they go! (Note that the 40 A fuse is just for the RR -- it's NOT a "main" fuse.)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I will double check it tomorrow but im sure it is in the right way because im still getting power to things like the alarm (that just beeps) and some of the lights. I'm kinda leaning towards it being some sort of reset procedure for the alarm since the batt was disconected but i cant be sure.
 

·
Registered
Joined
·
3,883 Posts
Not sure if there's a good way to bypass the OEM alarm unit or not, but that would be one thing to try/elliminate.
Not 100% sure on the ST3, but there are relays on the left side of the older machines that sometimes need replacing or swapping. One of the gents in here just had this problem with his...weird power issues, and the dealer swapped relays, and no more problem!

this thread:
http://www.ducati.ms/forums/showthread.php?t=69189
note that it's the older style fairing...I'm sure other items are unique on ST3
 
1 - 4 of 4 Posts
Top