Ducati.ms - The Ultimate Ducati Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I have a 2007 ST3s ABS with 46K. The turn signal LED in the instrument cluster does not work. It's probably either a bad LED (not likely) or a fault or crack in the printed circuit board. Since new instrument clusters are not obtainable, and I'm not interested in a used one, does anyone know if anyone has replaced an LED or repaired a circuit board?
 

·
Premium Member
Joined
·
429 Posts
I have a 2007 ST3s ABS with 46K. The turn signal LED in the instrument cluster does not work. It's probably either a bad LED (not likely) or a fault or crack in the printed circuit board. Since new instrument clusters are not obtainable, and I'm not interested in a used one, does anyone know if anyone has replaced an LED or repaired a circuit board?
Shipped mine from Canada to these guys in the UK - Digital Motorcycle Speedo and Cluster Repairs UK - Scorpio Electronics | - They replaced the LED and adjusted the odometer, as it was a replacement dash. Much cheaper than a North American repair.
Great folks to deal with.

David
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Yes I did. Their estimate was $60 - $80 to repair my turn signal indicator (but it could go up to 130 British Pounds) plus shipping to England and 12 working days. There is also a possibly that I would have to pay an import duty and tax when I get the speedo back depending on how the transportation is handled. Because they would need access to the CPU and sensors (i.e., the entire motorcycle) to calibrate the speedo, that is beyond what they can do for me. Their estimate does not appeal to me. I'm going to look elsewhere to get my turn signal indicator repaired. However, I do appreciate your suggestion. Thanks very much.
 
1 - 5 of 5 Posts
Top