Ducati.ms - The Ultimate Ducati Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Short version:

Getting nothing when I turn the key on my '00 ST2. No clicks, no sound of injectors priming. The screen stays dead.

Longer version:

The battery was dead so I roll started it down a hill. It ran for a few minutes then suddenly died under me. I was going around 40 mph so I turned the key off and on again, let the clutch out in 2nd, and she started again. She ran like that for another minute, then suddenly died again, and didn't want to start. Buddy picked me up in his van.

I got a new Shorai battery (same as the dead Li-ion that was on it, charged it) and found that the 10 amp fuse right above the battery had blown. Replaced that. None of the other fuses I checked (the 40 amp next to the battery, the 7 fuses next to the instruments, the 3 under the seat -- are there others I'm missing?) showed any blackening or breakage.

Any thoughts on what to check next? How badly could I have f*cked up this bike by rolling it like that?

Thanks.
 

·
Registered
'02 ST4S
Joined
·
1,273 Posts
It could be your Voltage regulator or Stator , a common ST2 problem. Go to the hall of wisdom for testing procedure or Roadstercyle.com for videos explaining testing procedure.
If you do the tests it will narrow down the part(s) you need so you're not just throwing parts(and $$$) at it.
 

·
Registered
Joined
·
2,250 Posts
get a multimeter and wiring diagram and follow the power from the battery until it stops. if you get nothing it has to be pretty close to the start of the chain.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks, I'll start with that. In general is it a bad idea to roll start one of these Ducatis like that?
 
1 - 5 of 5 Posts
Top