Ducati.ms - The Ultimate Ducati Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hey all, my SF is doing some wonky things with the speedometer, namely under acceleration (and sometimes while cruising) the speed drastically over-registers the speed of the bike. I've seen up to 160mph indicated while getting on the freeway, going 55mph up to 70mph!

Before I take it down to the shop, I was going to try and see if there's something obvious where the speedo is picking up the bike's speed...but where is that?

I just tore off the front sprocket cover and don't see anything there. Any help/ideas?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #2
well...i've at least discovered that the pickup is on the rear wheel, and there are bolt nubs that pass by the reader...in case anyone has the same problems.
 

·
Registered
Joined
·
14 Posts
Speedometer Issues

Since the termi pipe install and new ECU I have experienced the same problem. I checked the speedo pickup on the rear wheel assembly. It is snug.

What was the ultimate fix for your speedo issue???
 

·
Registered
Joined
·
14 Posts
Thanx. After some time spent with the bike I determined that the speed sensor wire had been burned to the copper wire (which then shorted)by the new termi header. I re zip tied the sensor wire (after repairing it) and, for now, am good to go.
 

·
Registered
Joined
·
25 Posts
Similar issue.... cause on mine was two of the four knubs got sheared off. They are only riveted onto the rear brake rotor...
Make sure you have four knubs.
 
1 - 6 of 6 Posts
Top