Ducati.ms - The Ultimate Ducati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
725 Posts
Discussion Starter #1
I'm trying to wire up my "hot grips" to a switched power source and I'm not able to find this "spare power" connector I hear others reference,

Is it on the 03 ST4s ?

What fuse does it connect to ?


Someone told me the 03 doesn't have this connector, ok then


Where is a good place to steal 5.5 amps switched power ?

I'm thinking of running it off the fuse box then bumping up that fuse amp rating. ... any ideas
 

·
Registered
Joined
·
3,906 Posts
The grips should be 30W total, which is 2.5A. I grabbed my source from the parking light circuit.
 

·
Mr Leakered
Joined
·
8,831 Posts
I’m wired straight off the battery with an in-line fuse. I’ve only had to bump start it once because I left them on. It was a sinking feeling climbing aboard with already warm grips.

Have a good one.
 

·
Registered
Joined
·
1,725 Posts
I’m wired straight off the battery with an in-line fuse. I’ve only had to bump start it once because I left them on. It was a sinking feeling climbing aboard with already warm grips.

Have a good one.
Same here but if I get that sinking feeling once this winter I will be looking for that park light circuit next maintenance when the fairings are off!
 

·
Registered
Joined
·
3,806 Posts
Lol yes I'm in that sinking feeling category too.
I've disconnected them from the battery now, and will be looking at routing them through one of the relays.
 

·
Registered
Joined
·
647 Posts
I'm trying to wire up my "hot grips" to a switched power source and I'm not able to find this "spare power" connector I hear others reference,

Is it on the 03 ST4s ?
It's not on '03 and earlier bikes.
 

·
Registered
Joined
·
3,906 Posts
Derek is correct. The extra connector is started with the newer body style in 2004.

And no, I did not re-fuse. I think it's a 10A circuit. But you're only running a rear running light, and that small head lamp running light (the one that's probably burnt out by now...). So it's maybe loaded with 1A when the key is on. I even have my solenoid valve for my home-made automatic chain oiler tapped into this circuit. it's another 0.5A
 
1 - 8 of 8 Posts
Top