Ducati.ms - The Ultimate Ducati Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
Something doesn't smell right and I need some input.

To recap my problem froma previous post: I tried starting and it (2002 st4s)would turn over but not fire....just like if you hit the starter button with the kill switch enabled. After trying several times and looking at connections it developed another issue like the battery was getting low where the lights/dash were really dim but it would still crank over just slowly. Replaced the battery and no joy. Checked relays and connections still nothing.

Took it the Ducati dealer and I forgot to check the relays under the front left fairing below the fuses. The mechanic swapped the relays ($170 thank you) and she now fires up fine. So a couple of questions:

With the DD headlight I believe that one of those relays is no longer in use....is this correct?
Is the other one the ignition relay? If so if that relay failed wouldn't I get NO power to the lights/dash instead of just a little?
I had to replace the relay on the high beam of the DD headlight a week ago as well....could these failed relays signify a bigger problem?
I would like to keep a spare relay...is there any out there that are more robust?

Thanks in advance.
 

·
Registered
Joined
·
3,911 Posts
Wow, never touched/hosed any of the relays on my 1998 ST2 (just sold it w/ 52,000 mi). Maybe Murphy, the one that lives in Charlotte, just hates relays? (Or loves them to pieces?)

Are you leaving the bike parked in a moldy damp area, or outside in the elements? I would think that other items would be suffering, too...
 

·
Registered
Joined
·
138 Posts
Discussion Starter #3
No it's parked in a garage...just seems weird and my spidey sense is going off.

So with no replies it sounds like I'm alone on this one....thats.....troubling.
 
1 - 3 of 3 Posts
Top