Ducati.ms - The Ultimate Ducati Forum banner

1 - 4 of 4 Posts

·
Banned
Joined
·
12 Posts
Discussion Starter #1
just put the oversized tank on my bike... I've only owned it for 4 weeks...

Have put 120 miles on it and I've noticed the bike sputters at steady throttle at lower speeds... For example... 4th gear 4500 RPM in town... not smooth like it used to be...

I'm thinking it's running lean due to the pod filters...

I have termi slipons and the ecu that comes with it... They were on the bike when I bought it...

Does anyone have first hand experience with this ecu? Can I adjust the mixture with the ecu?

I don't have a service manual for the bike yet, where is the ecu located?
 

·
Registered
Joined
·
348 Posts
I have not noticed it on my bike. I have the same setup. Termi slip ons 2-2 and ECU.
 

·
Registered
Joined
·
1,283 Posts
it might not be tuned right you may want to take it to get dyno tuned at a reputable ducati mechanic.another thing when you run the dp ecu you sometimes need a power module as well to tune all the way into the higher rpms like rapid bike,nemesis,and power commander.and then they run like they never run before.
 

·
Registered
Joined
·
348 Posts
Saturday i rode up to Ft. Bragg from Sacramento and came back today (Sunday). My concern was the Fog and mist. It did not rain but the bike was wet from being parked outside overnight as well as riding back this morning in heavy fog.

I ran Ft. Bragg to Sacramento via hwy 20 and Hwy 16. Did not have to fill up the tank except at the start. It was about 180 miles on this leg.

I purposely ran it in 4th gear at 4200-4500 rpm for a few miles and did not notice sluggishness or hesitation.
 
1 - 4 of 4 Posts
Top