Ducati.ms - The Ultimate Ducati Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited)
So I'm in diagnostic mode for the umpteenth time this year. This time it would seem the throttle position sensor has shit the bed. I've got ducatidiag hooked up to reset the TPS, but after resetting, the throttle only goes to 35 degrees or so. I verified this by checking the voltage on the signal wire to the sensor and it only goes from about .25V to 1.6V at full open. It's getting a full 5V power and I'm not seeing anywhere where I could have a bad ground. I had PCV hooked up, but I've taken that off to eliminate that as a possibility.

1. Am I missing something or is my sensor f*cked?

2. Can I replace just the sensor? I'm hearing mixed stories, but most of what I've found points to no. Apparently the TPS and throttle bodies are a unit and sold as such.

I swear to god, the next bike I get will be carburated or Japanese. :mad:

Edit* Oh yeah, duh, it's a 2008 848.
 

·
Registered
Joined
·
159 Posts
I swear to god, the next bike I get will be carburated or Japanese. :mad:[/QUOTE]

I hear ya! Fuel injection and engine managment were'nt invented yesterday, so what's the problem with them (Italians) getting it right when they're R&Ding the system in the first place? It's supposed to be very simple and dependable.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
What kills me is that it seems nearly impossible to get the Magneti Marelli IPF2CB TPS sensor as a stand-alone part. There was a few for sale on the UK eBay at one point, but not right now. I have to wonder how it got fried to begin with??
 

·
Registered
Joined
·
350 Posts
Don't know if the 848's are different, but my 916 TPS was giving me irregular readings. Took it apart carefully, (clamshell), cleaned contacts with acetone, squeezed it back together and has worked well ever since. Might be worth a try.....
 
1 - 5 of 5 Posts
Top