Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 8 of 8 Posts

·
1998 ST2
Joined
·
21 Posts
Discussion Starter · #1 ·
Everything was fine until one day, I came to take my '98 ST2 for a ride and noticed the Kuryakyn voltage monitor that I installed was showing that it was putting out about 15 volts just cruising down my street at about 2,000 rpm. Turned it around and parked it until I could check it out. Put a volt meter on the leads coming from the regulator and confirmed it was definitely putting out too much power. Jumping to over 16 volts at just 3000 rpm. Found something online on how to check the alternator and confirmed that is working fine.
While messing with the wires, I cut the zip ties loose to work with the wires and got it to work normally for a brief moment. Was working alright, then re zip tied the wires and tried it again and putting out too much power to battery again. Experimented and made a couple of jumper wires with 10 gauge wire and alligator clips and tried connecting regulator directly to battery with those but no effect. Same problem. Then tried a jumper wire from the Negative terminal to the end of the ground cable on the engine right by the rear brake fluid reservoir and it ran like a clock with that connnected so I thought it might have been that ground cable, so I made a new one with some heavy gauge wire and connected it. But when I tried it again, it was back to putting out too much again. I'm now stumped.
Just wondering if anyone's had a similar problem.
 

·
Registered
Joined
·
3,822 Posts
the single phase alt regs have a reference voltage input from the wiring loom that gets a big voltage drop in it and that makes them overcharge. best to just piss the original reg off and replace with a later style one without reference voltage requirement.
 

·
Registered
Joined
·
3,999 Posts
FWIW, I swapped in a Ducati 3-phase (newer) RR into a single-phase output stator on a Moto Guzzi (which uses Ducati Energia hardware!). Mine had the opposite issue -- only 12.5 V output. Enough to run the bike, but after a few hundred mile day, she would not restart.

The 3 ph RR charged at 14V, which makes for a much happier AGM battery.

You just connect 2 of the 3 yellow wires going into the RR. Tape the 3rd wire back.

Look at the H.O.W. area for some pics.
 

·
Premium Member
Joined
·
2,072 Posts
I'm probably misinformed, but my understanding is that if the r/r is putting out that much voltage, it's because it has failed. Others may know better, however.

Ron
 

·
Registered
Joined
·
355 Posts
I've had my vrr go on a kwaka that I had, it was putting out 17v at 3000 rpm. Cooked the battery before I noticed. Replaced the reg and all good.
 

·
Registered
Joined
·
1,312 Posts
It could legitimately kick out 15 Volt if not loaded
 

·
Excel Addict
2001 900SSie
Joined
·
5,345 Posts
Where are you measuring the voltage?

The correct place is at the battery terminals to measure what is going on at the battery.

If you are measuring "upstream" at the RR, then this will be higher due to the voltage drops in the cables aka Ohms law where V=IR, where I is the current from the RR and R is the resistance of the cable from RR positive to battery positive plus resistance from RR negative to battery negative.
 
  • Like
Reactions: forsythem

·
Registered
Joined
·
3,999 Posts
Punch has a good point. If your cables, connectors, and fuse connections are all solid-good, then there will be very little difference measuring up near the RR vs. at the battery.

But if any of the above are marginal/overheating (crispy connectors), then the voltage will be higher at the RR than at the battery.

Note that no connector should ever get warm or hot. If it does, it's bad.
 
1 - 8 of 8 Posts
Top