Ducati.ms - The Ultimate Ducati Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I rode my bike yesterday and it was fine. Went outside to start it up today and nothing. Not even the click of a dead battery. It was like there was no battery at all. When I rode yesterday the streets were wet but not raining. Could that have shorted something out? The battery has juice and and the kill switch is not covered. Anybody ever have this problem?
 

·
Registered
Joined
·
223 Posts
How old is the bike? Do you have a battery charger/starter?

Sent from my Motorcycle iPhone app
 

·
Registered
Joined
·
48 Posts
I rode my bike yesterday and it was fine. Went outside to start it up today and nothing. Not even the click of a dead battery. It was like there was no battery at all. When I rode yesterday the streets were wet but not raining. Could that have shorted something out? The battery has juice and and the kill switch is not covered. Anybody ever have this problem?
I washed mine for the 1st time with water last week ( i give the bike a wash at the same time :p )and the following morning when i went to start i thought i had a flat battery.She eventually fired up and has been fine since.It didn't have the same symptoms that your describing but was definately lazy cranking.
 

·
Registered
Joined
·
70 Posts
Can you hear the fuel pump priming when you turn the key?
 

·
Blame the universe not the tank!
Joined
·
3,234 Posts
If totally dead, chk the ground cable attached to ecu and battery terminals as well as engine ground. If you have a multimeter check battery for voltage, if it shows some you can also pull the battery and have it analized at an auto parts store.

If you get dash display and cranking with no ignition, ie the starter functions but no fire, fuel pump/fuel filter hose may have come lose. In this case you will see fuel swirl in the tank at key on as the fuel pump pukes fuel back into the tank since the fuel line in the tank is not connected anymore.


Auto corect disabledh
 

·
Registered
Joined
·
1,504 Posts
Sometimes I have to wiggle the starter button to get it to start - seems like a faulty start button but the dealer said it was fine (when it obviously is NOT fine) - try wiggling the button when you try to start it.
 

·
Registered
Joined
·
931 Posts
I washed mine for the 1st time with water last week ( i give the bike a wash at the same time :p )and the following morning when i went to start i thought i had a flat battery.She eventually fired up and has been fine since.It didn't have the same symptoms that your describing but was definately lazy cranking.
Had exactly the same thing happen. SF don't like water i guess :think:
 

·
øøøøº
Joined
·
1,312 Posts
kill switch, is the key on? Follow Gilly's post & get back to us in 2 days.
 

·
Registered
Joined
·
5 Posts
Did you check the 30 amp main fuse that is on the right side of the battery? It's difficult to get to…I had to partially remove the tail to get to it.

It is described on page 114 in the manual, but the drawings are not really good.

Good luck!
Shockstall
 

·
Registered
Joined
·
736 Posts
Try a new battery. I had a similar thing happen on my ZRX. I was riding all morning with never a hint of a weak battery. Stopped for some gas and she wouldn't start. No click, nothing. I checked the cables figuring one got loose or dirty. They were fine. Turns out the battery was dead.
 

·
Registered
Joined
·
387 Posts
Try a new battery. I had a similar thing happen on my ZRX. I was riding all morning with never a hint of a weak battery. Stopped for some gas and she wouldn't start. No click, nothing. I checked the cables figuring one got loose or dirty. They were fine. Turns out the battery was dead.
+1, same thing happened to me. Sometimes the cell just "pops"
 
1 - 17 of 17 Posts
Top