Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 20 of 35 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
Just now pulled the trigger on a RB EVO to go with my Arrow de-cat pipes & a Termignoni CF short slip-on.

SUPER excited about it. The discussion(s) on this site re: RB installation and reviews have been very helpful. Thank you.

Can't wait to have my MTS sounding like a duck should; the fish-tank bubbler cat sound is NO BUENO. I've spent the last 20 years
riding a 900 monster with Kehin FCRs and LV high-pipes....no way I can ride a Ducati with a catalytic converter, lol...
 

·
Premium Member
Joined
·
12,449 Posts
it will drownd out the sewing machine motor sound
 
  • Like
Reactions: Bergweiserus

·
Registered
Joined
·
66 Posts
Discussion Starter · #9 · (Edited)
got the RB all plugged in. now determining best way to mount the module and zip tie all the new wiring. the provided harness and plugs from RB are top-notch, they do a GREAT job on quality and ease of installation on their end. very nice product!!

my only issue on instal was reaching both of the OEM injector plug locations...it was a serious PITA getting to Injector 2....i felt as if i was doing surgery.

anyway, it's installed. i feel great about it. on a 2011 you have to remove a section of radiator hose, so of course i had to drain and refill the coolant.
otherwise pretty straightforward, i have to give a shout-out to Yaman at RB, he is on top of things and very much into customer service.

next step is to remove that ugly cat and install my Arrow de-cat mid-pipes which i am doing Sunday.

PS- on a 2011 you don't have to remove the tank, just loosen the front bolts, remove the rears and lift a bit. these pics were taken after i put the tank back on. i had it fully off and in my house for a week while i found the time to get back to it and then realized i didn’t need to fully remove it.

-Kris
 

·
Registered
Joined
·
757 Posts
Wow yours was a total PITA... taking out a section of the rad hose.... crazy.

Glad you got it sorted though!
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #11 ·
thanks man, yeah it was a serious bitch. i feel great though (now, lol)....
 

·
Registered
Joined
·
757 Posts
I'm going to be taking mine out for the first ride of the season tomorrow (gov't here has relaxed restrictions due to no new cases in 7 days) and can't wait to give the new RB QS/blipper a try :)
 

·
Registered
Joined
·
757 Posts
QS works pretty well it's very "notchy" compared to the factory QS/blip that came on my S1000R, you can physically feel the sensor click or whatever when you shift up.

The blipper is kind of hit and miss as to whether it wants to work or not, may have to email Yaman and see if I need to change any settings.

All in all, it works as advertised on the tin, I guess :)
 

·
Registered
Joined
·
691 Posts
I am experiencing the same problem with RB Race QS/Blipper on my DVT. I cant quite tell when the blipper is working. Sometimes it blip while downshifting, using the clutch. Upshifting seem to be working but it's not really smooth. I think I need to take it to a shop with a dyno.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
757 Posts
Well part of my problem may have been explained by the lower shift linkage screw (bolt?) falling out while I was riding to work this afternoon... If you haven't already, put some loc-tite on those puppies is my suggestion! I didn't have a hex adapter to fit either of my torque wrenches (nor do I know the spec, lol) but I had thought they were "good-n-tight"...

Will report back if that fixes my issues.
 

·
Registered
Joined
·
757 Posts
Follow-up, it is still quite jerky on upshifts and often flat-out refuses to down-shift without the clutch regardless of whether I've completely roilled off the throttle or not.

Will likely need to contact RapidBike and ask for some assistance, thus far I would not recommend.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #18 ·
here's some photos of where the EVO module ended up on my 2011. It reaches to the rear seat perfectly and the harness does not get pinched by the seat - i can wiggle the wires when the seat is attached.....
984299
 

·
Registered
Joined
·
757 Posts
Wiring harness definitely isn't that long on my 2016... that's a lot nicer install that on my bike for sure.
 
1 - 20 of 35 Posts
Top