Ducati.ms - The Ultimate Ducati Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hi Guys, This is my first post on the Forum although I have hovered for years! As usual with first posts, I need help!!

I have Bought a 2013 Multistrada to go with my 888SP5.

I have got a rapid bike evo for my 2013 Multistrada 1200. Are they the worst instructions ever? Can anyone tell me where each of the connectors are and how to get to them! Does the airbox have to come off?The instructions just say find them! Also, is injector 1 the horizontal(front) or vertical cylinder(rear)? Any pics would be great.Thanks in advance.
 

·
Premium Member
Joined
·
3,556 Posts
Man I can't remember where all the connectors go but there are some online guides I used that helped a lot (and yes their docs suck bigly).

I did not remove the airbox... I did remove the tank but IMO you could do it without removing the tank (be a pita routing cables though). This on a 15 but I don't imagine the pre-dvt bikes are that much different.
 

·
Registered
Joined
·
9 Posts
I have got a rapid bike evo for my 2013 Multistrada 1200. Are they the worst instructions ever? Can anyone tell me where each of the connectors are and how to get to them! Does the airbox have to come off?The instructions just say find them! Also, is injector 1 the horizontal(front) or vertical cylinder(rear)? Any pics would be great.Thanks in advance.
Hello JaspSP5, were you able to locate better instructions?
I am about to purchase the RB EVO for my 2011 MTS 1200S so I reached out to RB and they sent me some instructions in a PDF (attached to this mssg).

Also, if you were able to complete your installation, did you need to remove the fuel tank?

Thanks!
Kris
 

Attachments

·
Registered
Joined
·
123 Posts
Interesting that they sent you the instructions, because I never heard back from them when I asked... :(
 

·
Premium Member
Joined
·
3,556 Posts
Interesting that they sent you the instructions, because I never heard back from them when I asked... :(
Hmm... they always responded to me (sometimes took a couple days). Are you using a weird mail service that maybe is going into their spam filter?
 

·
Premium Member
Joined
·
3,556 Posts
[email protected], was just looking at my discussion and over a dozen emails they never took more than a day to respond... and often responded within 10 minutes. They also set up a team viewer session and looked at the bike live... really solid service.
 

·
Registered
Joined
·
811 Posts
Interesting that they sent you the instructions, because I never heard back from them when I asked... :(
You may be interested that the Rapidbike installation instructions, user manuals and other documentation can be downloaded here once you register:
 
1 - 9 of 9 Posts
Top