Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 9 of 9 Posts

·
Premium Member
Joined
·
116 Posts
Discussion Starter · #1 ·
I have an 05 999BIP. I was wondering if anyone else has had problem with the 3in radiator hose leaking? It only does this on a cold start. I bought the bike in Sept and I am now on my third hose. The Dealer has been way cool by fixing on the spot or offering me the Demo. It has just been rather frustrating to start up, back out of the garage and see coolant on the ground knowing I should not have a leak.
 

·
Registered
Joined
·
49 Posts
I purchased my 05 999 in august went all summer without a problem. In December I noticed a small leak in the hose that runs from the vertical cylinder to the radiator. The dealer picked up the bike for service when it returned I started the bike it began to leak from the lager lower hose (like yours only when its cold). It is now back at the shop I am looking into a different set of hoses. Ducati performance perhaps?
 

·
Premium Member
Joined
·
116 Posts
Discussion Starter · #3 ·
Thanks for the reply. I talked with the dealer about this leak and it seems to be coming from the meshing in the center of the hose. It could be a bad batch of hoses, who knows for sure. I hope this one holds up though.
 

·
Registered
Joined
·
82 Posts
This past Saturday I took my 999 in to the dealer to fix a few problems; one of which was a leak. It was the upper small hose clamp... no big deal. When speaking to my mechanic, he pointed out how a lot of people are having trouble with the lower hose. Apparently the threading in the hose leaks through. Although mine is not leaking... If it ever does leak, I'll look into getting a different set of hoses.
 

·
Premium Member
Joined
·
1,222 Posts
My 2005 ST-3 had bad hoses. It started to leak at about 3000 miles. The dealer replaced the hoses under warrantee.
 

·
Registered
Joined
·
9 Posts
I have a 2005 999 with 3K miles on it and I noticed a leak yesterday morning as I was warming it up. A whole lot of coolant spilled on the floor so I took it to the dealer. The leak was a lot less on the way to the dealer though. Maybe because it was warmed up. I haven't heard back from them yet. So, what's the consensus about the fix? New radiator hoses? If so any specific kind?
 

·
Registered
Joined
·
382 Posts
If the Ducati OEM hoses don't fix the problem look into the samco hoses.
 

·
Registered
Joined
·
3,493 Posts
Pissing coolant

I had the same problem and all I did was crank down on the hose clamps after repositioning them a little. The peeing stopped for me completely. Red Samco hoses and SS hose clamps are in my future but the adjustments made seem to be holding just fine for now.

Oh and someone gets the resurrection award for bringing this one back from the dead. :D
 

·
Registered
Joined
·
444 Posts
Going thru the same thing now on cold startups - last summer, the problem was from the coolant hose running to the vertical head. I replaced the hose clamps then. This spring, it started again, so I replaced the hose also. Last oil change, two lower left radiator hoses started leaking, so I tightened them. Startup at snowshoe, wv a couple of weeks ago, the bike temp showed 45F and it peed coolant until it was warm. I'm going to have the dealer look at it at my 6k service.
 
1 - 9 of 9 Posts
Top