Ducati.ms - The Ultimate Ducati Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Does anyone know which hose is which for the fuel pump.
As in the 2 lines return and pressure from the fuel injectors.
I freakin forgot which was which. 98 st2. Thanx....I know
what a dumbass!!
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
I just need to know which side of the fuel injection rail
they go too. My lines don't have return or pressure on them.
So if someone could look at their bike and tell me where the
out hose goes and the in hose goes that will really help me.
thanx
 

·
Registered
Joined
·
54 Posts
Discussion Starter #5
I love DUCATI.MS

thank you jerry...you rock!!!
I switched the lines and blam
she fired right up. I havent been this
happy since last fall. figures that it
snowed here today, but it's nice to hear
that bitch rumble again.
thanx again!!!
 

·
Registered
Joined
·
319 Posts
Jake,

When I look at my service manual ('03 ST4S), it looks like it does not matter which line you connect the IN and OUT to. The FI lines are pressurized by the fuel pump. If and when the pressure goes above a certain level, the extra fuel is returned back to the tank. It appears that both IN line and OUT line plus the two injector heads are all connected to the same loop.

Did the FI not work when you had the two lines connected differently and then started working when you swapped the lines?

-Fariborz
 

Attachments

·
Chilehead
Joined
·
6,982 Posts
Fariborz said:
When I look at my service manual ('03 ST4S), it looks like it does not matter which line you connect the IN and OUT to. The FI lines are pressurized by the fuel pump. If and when the pressure goes above a certain level, the extra fuel is returned back to the tank. It appears that both IN line and OUT line plus the two injector heads are all connected to the same loop.
That's correct, it doesnt matter which way they are connected on the STx, as the regulator is in the tank (I think that mine are currently swapped, as they fit better that way).

Tom
 

·
Registered
Joined
·
54 Posts
Discussion Starter #8
yeah, they only worked when they were connected properly...go figure
 

·
Registered
Joined
·
319 Posts
Thanks Jake. I will test this on my ST4S in few weeks when I am doing the valves.

-Fariborz
 
1 - 9 of 9 Posts
Top