Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all,

Long time lurker first time poster.

I have a 2002 ST4s and I just picked up a power commander from FBF with the preloaded map for my bikes setup.

The install seemed pretty straight forward but the bike will not turn over. It just cranks but never fires up.

As soon as I switch back to stock mode the bike will fire right up. I have noticed that the lights on the power commander do not light up when the ignition is in the on position, but if I plug the 9 volt battery in the lights come on and there and it looks like it is trying to do its thing when I push the starter.

Any ideas??

Thanks
 

·
Registered
Joined
·
588 Posts
Master of the obvious that I am... recheck the installation instructions to ensure it is properly wired. And, the unit ground is soundly connected to the battery? They really are a pretty straight-forward install so I'm thinking its a simple oversight.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks. I reinstalled a few times but it still did not fix the issue. Talked to a tech at FBF and they want me to send it back so it sounds like I got a bad unit.
 

·
Registered
Joined
·
67 Posts
Just curious: The directions that were sent with the unit, did it state which color wires went to the front and rear cylinder? I installed one last month and it didn't state which color wire went where. I think they are orange and yellow. When I called FBF they said that they hadn't updated the directions for the ST series unit. Just a thought?

Mark
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Yes the directions said orange to the front yellow to the back, granted the directions were for the S4 and S4R, but I would imagine that it would be the same. I guess if I run into the issue again with the next unit I will try reversing.
 

·
Registered
Joined
·
67 Posts
That is correct, I checked my notes. I just wanted to make sure because when I received mine the directions mentioned nothing at all about which connector went to the front cylinder and which to the rear. I guess they have since changed the directions they are sending out with the PCIII unit.

I guess you got a lemon, the good news is that FBF are great about customer service and I'm sure they will get a new unit right out to you. I have done quite a bit of biz with them and they have treated me right every time.
take care!

Mark
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top