Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
896 Posts
Discussion Starter · #1 ·
Hi all ,I am not near the bike so if I answer this myself later I will let the hive know.

I noticed when doing a shakedown run (just did the 22k mile service) on my 09 1100s that my tail light was not working. No brake or running light. Headlight and front signals, dash etc all worked fine.

Is there a fuse for the rear taillight ? The tail light is an aftermarket unit with integrated turn signals. I did not use the signal function as my fronts are bi-directional bar ends and the previous owner chopped the signal connectors of the wiring harness.

It worked previously but when I removed the tail light something was rattling inside:|.

Ive already ordered a new tail light (I sometimes break things trying to fix them >:)) and will replace the connectors as I have been meaning to do that anyway.

Question is ... could it just be a fuse ? I kind of doubt there is a dedicated brake light fuse but without my home PC and service manual I figured I'd ask the inter-webs.

Thanks !!!
 

·
Registered
Joined
·
896 Posts
Discussion Starter · #3 ·
My service manual shows fuses only for lighting overall. Not tail light only. Headlight and signals are fine. There are only a few fuses anyway. New tail light will be here soon. Fingers crossed !!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top