Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Well, I thought I was a member here from years ago but it must have been the Monster Forum, of which I wasn't real active. I've had an M750 Metallic that I've owned since brand new (highly customized), and it's only got 12K miles on it, which shows how seldom I ride it.

https://www.ducati.ms/forums/attachment.php?attachmentid=930973&thumb=1

Anyway, I joined because I need to learn about this particular machine which I will be picking up Friday. Scored it for $600. Owner says he left it outside during a heavy storm and it won't start or even light up. Something was fried in the electrical system. So I'm sure I'll be asking plenty of diagnostic questions. Just what I need, another project! But at least this one is pretty cool.

https://www.ducati.ms/forums/attachment.php?attachmentid=930975&thumb=1
 

Attachments

·
Administrator
Joined
·
14,035 Posts
Welcome and thank you for posting the photos :)

That ST has pretty paint job on it, you will enjoy the bike I am sure.
 
  • Like
Reactions: rd400racer

·
Registered
Joined
·
48 Posts
Did you get that off ADVRider? I think I saw it there and thought to myself: "Oh man - if the electrics can be sorted out, someone's getting one hell of a deal!"

Congrats and let us know how the diagnosis & repairs go.
 

·
Registered
Joined
·
164 Posts
Wow, deal of the century!

Plenty of accumulated wisdom regarding electrical problems on the ST Forum. IMO the copper-plated spaghetti used for wiring by Ducati during that and earlier eras does not age well. :surprise: So, even a pristine low-miler will need TLC.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top