Ducati.ms - The Ultimate Ducati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
I just finished installin a Bazzaz Z-FI, fired it up andit runs like crap. Sounds like its only fireing on one.
I didnt load any maps and my auto tuner hasnt arrived yet.
Is this to be expected? I figured it would have run at least as good as it did without it.
 

·
Premium Member
Joined
·
423 Posts
Thought the bazazz came with a map loaded in it? Not that it should make the bike run like crap. I would recheck your wiring as a starting point.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #3
Ya i think i think it comes with a slip on map but i didnt load it.
I have a full pipe.
Pretty sure i got the wireing right, its very simple and straight forward.
 

·
Registered
Joined
·
1,287 Posts
So :
You installed a Bazzaz.
It should run with a default map or an auto tune.
You didnt load any map, and dont have the auto tune.
You're wondering why your bike run like crap ? seriously ? I mean, even before bothering checking wiring, you should maybe finish the install...
 

·
Upright Racer
Joined
·
889 Posts
Yeah you have to have some type of map loaded or have the autotune or it doesn't know what to do.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #6
So a map needs to be installed. The Z-FI wont let it run the way it did before the install.
You think they would pre-load the factory map on it at the very least!
I mean its like it was instantly de-tuned.
Whatever...Hopefully the auto tune is here tomorrow.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #7
Just For the record.....it should run somewhat normal when installing the Z FI even without the autotune.
It turns out that i had a a broken injector that was causing the poor running condition.
 

·
Registered
Joined
·
20 Posts
Just For the record.....it should run somewhat normal when installing the Z FI even without the autotune.
It turns out that i had a a broken injector that was causing the poor running condition.
Thanks for the update bro, i had ordered one and then read your feedback... hope your running well now
 
1 - 8 of 8 Posts
Top