Ducati.ms - The Ultimate Ducati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi Everyone,

New here to hypermotards, not new to bikes although it has been some time since i rode. I picked up a 796 and have a few question off my head.

1. The bike came with front and rear rizoma led turn signals and now the dash turn signal light does not work. I suspect it is a load resistance issue. Was hoping to pick your brains on what resistors you have inline or in parallel and proper wiring. I have some 10W various ohm resistors i can wire in but have not even taken the bike apart to see how it is wired.

2. Is there a way to turn off the immobilizer, i don't like the fact the dash keeps blinking the red led would prefer to just disable it if possible?

3. 15w50 is this the proper oil for this bike? The manual has about 4 different weights listed but i believe the USA model is 15w50. I normally use mobil1 15w50 for my performance motors and it runs fine even on motorcycles with wet clutch.

4. Bike has a bazzaz z-fi and there is a lot of popping on decel so it needs a tune for sure, previous owner said it was rich but I'm not sure until i look at the map since he said it was tuned when he was up in the mountains at much higher altitude one would think it is running lean but I'll check the spark plug and that will be a tale sign aside from looking at the map. Was thinking of getting the z-afm and tuning it myself rather than a one time dyno fee. I've done a search and read peoples experience with the bazzaz and it is really a hit or miss. Any tips on the z-afm?

5. The seat so far seems nice and comfortable but was just my experience from a short ride around the block. Any gel seat recommendations?

6. Lastly I'll look more into this but I read this has an obd2 proprietary plug so i plan to find this proper usb/serial adapter and check for previous codes if any. Any suggestions on kits for this?

Thanks
 

·
Registered
Joined
·
18 Posts
Discussion Starter #2
I solved #1, for those with similar issue just run a single inline resistor not both as mine was wired in with both.

Any advice on the rest is appreciated.
 

·
Registered
Joined
·
139 Posts
I don't think there's anything you can do to get rid of the immobilizer . Are you talking about the red light blinking at the top of the speedo ? I'm not sure what that is mine blinks for about 10 hours after I turn it off
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Yes I was hoping to disable it and the light.

I have been reading up on the diagnostic tool and I'm not sure if the link for the tool talked about here is still relevant in the the link below. Most of the links in the thread are dead and I'm wondering if i should order the cables?

Is there a new version of the tools I should know about also does it work with a 2011 796?

I have the tank off and I'll have to check for the 3 pin connector, I see the 4 pin near the rear but that is not correct from what I understand.


http://www.ducati.ms/forums/92-hypermotard/119712-ducatidiag-must-have-every-hm-owner-2.html
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
It appears that link specifies it does not work on the 796 b/c it has a Siemens ecu.

With that said what tool/software works for this 2011 796 to read codes and clear the service light since i'll be doing my own service and oil changes?

Cheers
 

·
Registered
Joined
·
239 Posts
Can't help with your other q's but I'm pretty certain my immob. light goes off sooner than 10 hrs. Never put a stop watch on it 'tho!
The recommended oil is fully synth 15-50, here in temperate UK. Somewhere much hotter or colder might change that I guess?
If you don't know it already you might find the Peter Verdone designs site interesting - he has a good list of some comparative oil "weights" showing that same numbers on different oils don't guarantee same effective weights/viscosities
Suspension Fluid - Pvdwiki
I've been meaning to fit some LED rear indicators to mine - interested to see you got away with a single resistor, what was the resistance? Presumably the 2 fitted were together too high rated for the job.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
Thanks, the single resistor did the trick, running them in parallel did not work all it did was lower the resistance and blinker blinked faster so with less resistance the dash registers the signal and everything works as intended. I ended up putting in 3.55qt of mobil1 15w50, the manual states 3.4liter which is about 3.6qt so I'm not sure how much to trust the oil level line. I didn't fire it up yet b/c i have more maintenance I'm doing to it but I figure once it runs through the system it will settle down to where the line marker is. The internal crank case filter is really in a bad spot, have to take the exhaust pipe off just to reach it.
 

·
Registered
Joined
·
239 Posts
Yes dropping the front pipe is a pain but from memory I just took off the head nuts* & just loosened the pipe further back - didn't take it right off - just loose enough to get to the filter which was done up damn tight! There was a bit of "swarf" in there - the Ducati tech guy I know didn't seem surprised or worried about it when I told him. I think you need to find a "hidden" bolt holding the back pipe in place otherwise it won't come loose.
* actually, only one came off, the other was seized solid with rust & the whole stud unscrewed so I replaced the studs with stainless + brass nuts. It rains a lot here....
 
1 - 8 of 8 Posts
Top