Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey guys,

First time post for me. Great site lots of info. I did some searches, but couldn't find anything that quite fit my problem.

I have dumped a ton of money into this bike already, and I figured I would ask your advice before I take it back to the garage and get charged an arm and a leg for the third time.

1998 748 with 6300ish miles on it, 6k valve tune-up and all 6k routine maintenance was performed approximately 4 weeks ago.

Ok here is the issue... The bike was running great for a few weeks, however, it would occasionally just stall at idle, but would start right back up. No big deal.

Today.... I was riding and was about 80 degrees or so out. I was in third gear and it just lost power and died. I coasted off to the side of the road, but when I tried to start it again it wouldn't turn over. I let it sit for about 10 minutes and it started. Then as I tried to get it home it kept stalling on me with greater and greater frequency. Didn't matter if I was stopped or moving. Each time I would remedy the problem by coasting off the road, letting it sit, then going as far as I could before it happened again.

Any advice would be greatly appreciated. Sorry for the long post.

Thanks in advance....
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Hey Jodie.... Just read through your thread. How is your bike running these days? What do you think ultimately was the problem?

I want to be armed with a little bit of knowledge before I take it to another mechanic and shell out another big chunk of change. I have already invested a ton of money into this bike. Probably could have gotten a brand new Duc for the cost of maintenance / repairs done to my 748.....

Thanks again for the response.
 

·
Registered
Joined
·
37 Posts
Hey Jodie.... Just read through your thread. How is your bike running these days? What do you think ultimately was the problem?

I want to be armed with a little bit of knowledge before I take it to another mechanic and shell out another big chunk of change. I have already invested a ton of money into this bike. Probably could have gotten a brand new Duc for the cost of maintenance / repairs done to my 748.....

Thanks again for the response.
bike runs great now.... just took it out of town 2days ago.. and i use her regularly again...

this 916 was a project bike and had a lot of bugs since it was stored for about 2yrs...

http://www.ducati.ms/forums/showthread.php?t=58328

i was able to ride her for about 2000kms before the fuel pump started failing..
but it did show signs hat it was already weak to begin with..

everything about the bike seemed in order.. the electrical and charging systems were healthy, there was no fuel leaking the hoses...

the fuel pump was just the last thing we could think of that made sense..


if i were you i would check the hoses in your tank.. one might be lose..
also dirt.. just a little could block your fuel pump...
dirt could also explain why your bike stalled and then started after and stalls again...


hope you find and solve your problem.. ill monitor this thread..
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Cool thanks a lot Jodie... You mentioned dirt could block my fuel pump... Where would I look for this dirt, and how can I get it out? Thanks again.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Ha. Damn it. I was hoping you weren't going to say that....

If the shop tells me I need a new fuel pump would you reccomend going with the generic $50 pump rather than paying the 400-500 you mentioned for a "Ducati" fuel pump?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Just an update to my situation....

I took the bike out yesterday and rode around for a little while. Seemed to be running fine. Then I go to take her out today and you know that little buzzing noise when you click the bike over to "Run"....lasts about 2-3 seconds.... I think it might be the fuel pumping turning on? Well today when I tried to start up the bike, that buzz noise won't happen, and the bike won't turn over when I try to start it.

Anyone have any ideas? I have the fuel tank screw out and the sides off, but I don't really know what to start looking for.

Thanks so much again.....
 

·
Registered
Joined
·
141 Posts
Sounds like your fuel pump relay needs replacing. I'd replace both the relays underneath your tail, since they have a finite lifespan.
 

·
Banned
Joined
·
112 Posts
Problem

Hi Mate
i had this issue too my relay played up or so i thought, but i could jump it to ground with a paper clip which made it go so repacing the relay was going to fix it, but no!. I found out my ECU was not earthing internally thur the circuit board, i had the board out and checked the board but couldnt find a fault i merley replaced the ECU with a second hand one ALL PROBLEMS GONE! COST $100 USD fuel filters if blocked can give you issues too just replace it for piece of mind
cheers Kev

M900
748
996
1098
JUST LOVE EM!
 
1 - 13 of 13 Posts
Top