Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter · #1 · (Edited)
Has anyone used this integrated taillight? I have an 08 1100 Hyper.

DUCATI HYPERMOTARD 796 1100 LED TAILLIGHT

I ordered it over a year ago when it came out, when I use my turn signal the LED flashes red instead of amber which makes it pretty much impossible to see. My friend ordered one at the same time, we installed them together and they both performed the same.

I contacted the sell, who answered my questions very quickly, and he suggested my bike had a short and to test the turn signal wires from the bike. I tested all the wire, they were normal. I tested the connectivity on the taillight, it was normal and I used a power probe to connect the turn signal LEDs to the battery and it still lit up red.

The seller asked me to send the taillight in for testing. I never heard if they tested it, but they sent me a new one and it performed exactly the same. When I told the seller this he says its a short in my bike.

I have found other threads on here where people were having problems with similar taillights, the australian and french ones. But I don't they were having the same problem I was having. It seems the Hypermotard turn signal fires off - instead of + like other turn signals and the problem was solved in these cases with relays/resistors. Will this solve my problem?

I'm about ready to go back to stock but I would like to get it working if possible. Thanks for any help you guys can provide.
 

·
Registered
Joined
·
396 Posts
I just installed my last week. The right signal on their light is wired backwards. My husband is luckily good with these things and cut the wire and re-soldered correctly.
 

·
Registered
Joined
·
74 Posts
The right turn signal didnt work for me and I guess I'm not that smart to figure it out so I sent it back... of course they said it was my brand new bike that had a short in it.

Other than that fitment and color of turn signals were correct...
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #4 ·
Just updated my original post, my bike is an 08, would the wiring on your newer bike be different? Both of my left and right sides flash when I flip the switch, its just the color that flashes is messed up. Weird...
 

·
Premium Member
Joined
·
423 Posts
This is the taillight I have on my 08 when I have it on the street. From what I remember the colors were a bit screwy. For me, when the turn signal was on and the brake was not, the whole light seemed to flash a little amber but mostly red. This I figure was some sort of voltage difference within the light causing the red leds from the brake to intermittently flash as the turn signal was flashing. Try this and it will tell you if what you are experiencing is the same as I; put turn signal on and hold brake lever down. What you should see now is a solid red light for the brake on half the taillight and the amber flashing from the other half. If this is so then I am sorry but I don't have a real fix, just some resistors to normalize the flash rate and make sure to hold the brake at the stoplight when turning.
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #6 ·
This is the taillight I have on my 08 when I have it on the street. From what I remember the colors were a bit screwy. For me, when the turn signal was on and the brake was not, the whole light seemed to flash a little amber but mostly red. This I figure was some sort of voltage difference within the light causing the red leds from the brake to intermittently flash as the turn signal was flashing. Try this and it will tell you if what you are experiencing is the same as I; put turn signal on and hold brake lever down. What you should see now is a solid red light for the brake on half the taillight and the amber flashing from the other half. If this is so then I am sorry but I don't have a real fix, just some resistors to normalize the flash rate and make sure to hold the brake at the stoplight when turning.
Yes I have the solid red bar when the signal is flashing and brake is pressed, however there is no amber whatsoever. it is solid red with "slightly dimming red"
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #7 ·
Here is the left turn signal alternating on:





and here it is off:




The brake was not pressed.

Its hard to see the colors, but its all red, and no I am not color blind I am tested every 2 years for my job.
 

·
Registered
Joined
·
36 Posts
This is the taillight I have on my 08 when I have it on the street. From what I remember the colors were a bit screwy. For me, when the turn signal was on and the brake was not, the whole light seemed to flash a little amber but mostly red. This I figure was some sort of voltage difference within the light causing the red leds from the brake to intermittently flash as the turn signal was flashing. Try this and it will tell you if what you are experiencing is the same as I; put turn signal on and hold brake lever down. What you should see now is a solid red light for the brake on half the taillight and the amber flashing from the other half. If this is so then I am sorry but I don't have a real fix, just some resistors to normalize the flash rate and make sure to hold the brake at the stoplight when turning.
From what I understand from my brief time at a Ducati shop is that resistors are unnecessary, the dash panel has a setting for Led turn signals (Ala Ducati accessories) and you should be able to switch to that setting without having to purchase the resistors. I have been considering purchasing one of these integrated taillights but they seem to have issues with working properly, perhaps having a trusted Ducati mechanic to sort it out makes all the difference in the world.

Sent from my Transformer TF101 using Motorcycle.com Free App
 

·
Premium Member
Joined
·
423 Posts
Custom, it appears that your situation is not the same as mine was. Weird since they are the same product. I wonder what their quality control is like? Sorry I couldn't be of help. JT, the LED option on the dash does diddly as far as I can tell and made no difference when I used it. I found several threads on here about it the resistor issue when I was messing around with it, very good info and simple to do.
 

·
Registered
Joined
·
530 Posts
I had issues with my light too. The two wires that were meant for the right flash and the two meant for the left even though they are grouped like that is not correct. You have to take one from the left and one from the right to have one side of your signals working. It took me a whole day of trial and error to figure it out. When ordering you have to specify the model you have because from what they told me the the 08 for north american use is wired different for the rest of the world and in 2010 it was changed again. I don't know how true it is but after crossing one colored wire on the left with one white from the right it finally worked. For something so straight forward it was a stressful install.
 
1 - 10 of 10 Posts
Top