Ducati.ms - The Ultimate Ducati Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,256 Posts
Discussion Starter #1 (Edited)
Hello everybody!

Just finished my valve check on my 2007 S4R and got all excited that no parts/screws are left until I “found” this connector, unplugged on the left side between the cylinders.

I haven’t started the bike yet to observe any codes or symptoms and was wondering if the group recognizes this little sucker?

Thanks in advance!





Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,256 Posts
Discussion Starter #4
PS: the bike has a Full arrow exhaust system. I don’t know if the 2007 had a Lambda Sensor.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
721 Posts
PS: the bike has a Full arrow exhaust system. I don’t know if the 2007 had a Lambda Sensor.


Sent from my iPhone using Tapatalk
The 2007 had a lambda sensor in the cat, odds are that's the harness plug for said lambda.

Put a balloon over it or smear it with dielectric grease and tuck it away.
 

·
Registered
Joined
·
1,301 Posts
My "un-researched guess" would be exhaust valve.

t_bare
 
  • Like
Reactions: draganc

·
Registered
Joined
·
1,256 Posts
Discussion Starter #8
The 2007 had a lambda sensor in the cat, odds are that's the harness plug for said lambda.

Put a balloon over it or smear it with dielectric grease and tuck it away.
Winner winner, chicken dinner!!

I was able to confirm the wire colors with my schematic, after wearing my reading glasses and taking a picture of it to zoom in.

Looks like to be indeed the Lambda sensor plug.

Here the schematic for the records and the next road warrior.

Color code is:

Light Blue/Blue-Green/Red-Green/Black-Blue






Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top