Ducati.ms - The Ultimate Ducati Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter #1
The red dash light now stays on all the time until key is turned on. Battery is charging and motor runs like normal. I have not checked the wiring diagram yet . I figured one of you guys have come across this on a first generation ST.
 

·
Premium Member
Joined
·
5,566 Posts
Might try disconnecting the battery for a bit to reset things. Might also try to reset connections, with the battery disconnected, at the ECU, LED (behind tach) and the immobilizer unit. Look for corrosion on the connector pins too. It's never happened to me and I can't think of anyone else who has reported it happening on here, but you might get lucky. On the older bikes, the immobilizer is a separate unit under the headlight faring on the left side (newer bikes, it's built into the dash). As you know, it is normal for it to go dark after a day or so without the bike being started. Lightning solid typically means there is a problem paring the key in use, but this happens when you try to start the bike. Could be it also means an issue with the unit even sitting idle. Does the bike start for you? What happens to the light when the bike is running, or after it's been running and then shut down? Do you have a spare key to try?

I've been lucky with my bike in this regard, but others have enough problems with the thing to want it disabled. You can have that done with an ECU re-flash. Not a bad time to load the performance map if you don't have it already.
 

·
Registered
Joined
·
131 Posts
Discussion Starter #3
I did try disconnecting the battery and after reconnecting the red light came back on steady. It would go off when I start the engine as normal . So I turned the ignition on and off with the red key today . The light finally went off. But now I don't get the normal flashing after it's turned off with any key. Battery is fully charged and motor starts right up.
 

·
Premium Member
Joined
·
5,566 Posts
Probably a flaky Immo unit then. I'd still go at the plugs looking for corrosion, also the plug for antenna around the key switch. It may just be time to remove it by re flashing the ECU and specifying that you want it disabled. I haven't been down this road, but there are user tools out there, Ducati diag and Guzzy diag, that apparently let you do this yourself. Tons of info on the subject and a good bit of forum knowledge. I have the older VDST software that connects to the ECU, but no re flash or editing capability.

You also cannot just buy a new or used Immo unit if you were thinking of going that route. The Immo is paired with your ECU and keys. You'd need to replace everything from a bike being parted out. Locks, keys, Immo and ECU. You don't need the dash, that's for the newer bikes.
 

·
Registered
Joined
·
131 Posts
Discussion Starter #5
Well as of now it starts and runs fine . I've got all winter to go through the wiring connections . It would be nice to totally delete it though. Thanks
 

·
Registered
Joined
·
3,810 Posts
Well, I'll chime in on my 59M ECU. Last year, it was in the state of not wanting to start my machine. It would fire (occasionally), but would not start the engine. After much troubleshooting, I ended up trying a 5AM ECU from a HyperMotard. I bought it on eBay, and damn, the beast started right up when I installed it. Even with the HM map. I was amazed
1) to hear my engine fire to life
2) that the HM ecu and map would do it
3) no IMMO issues

Since last year, I am running on a DP map for an ST4s (MY2005?). and it's kicking ass above and beyond what I was running on the 59M ECU. It does not miss the IMMO at all. BUT (there's always a BUT right?) the 5AM is missing the input from the barometric sensor -- it seems the 5AM needs this input from the newer dash boards -- via the CAN BUS. I CAN (pun intended!) only guess that the ol' 59M ECU's only CAN bus signal was from the IMMO unit on the "old" ST4s's .

Hey, imagine all the weight savings...no more IMMO unit mounted to my frame! wow, I CAN (again...) read below:

Final note -- The latest map in the 5AM allows power wheel lifts in 3rd gear now, where the machine did not do this B4...Yeeeeha Mofo!!!
 

·
Registered
Joined
·
94 Posts
Stick, I've been having an issue with what I imagine is my ECU as well. If she doesn't fire or start by the time the engine has turned over 5 or 6 times, I shut the key off, wait a few seconds, then turn it back on. If no fire, lather, rinse repeat. Losing the immobilizer would be no skin off my back either.

Since I'm so far out in the boonies and fairly new to this whole Ducati thing, I've got a couple of questions. What kind of investment would be needed? Who sells the DP map? Did your ST4S actually run okay on the HM map?
 

·
Registered
Joined
·
3,810 Posts
So, I sourced a 5AM ECU on ebay. It just has to be the 5AM HW610, which is the most common, and not the HW103 version.

I spent around $100 for the ECU. Then I was fortunate to have 2 separate gents (on this forum) send me their MAP files. I ended up sticking with the newer ST4s DP map, because the other DP map had my fan running all the time (it was an S4R DP map (996 engine)).

The cables to connect to your ECU are about $30 if you go thru Lonetec.
The reading/writing SW is free -- donation accepted... It's IAWReader, IAWWriter and IAW Diag

https://www.ducati.ms/forums/241-tech-forum/687521-2003-st4s-planning-install-5am-ecu.html

Read Post #15...
 

·
Registered
Joined
·
4 Posts
So, I sourced a 5AM ECU on ebay. It just has to be the 5AM HW610, which is the most common, and not the HW103 version.

I spent around $100 for the ECU. Then I was fortunate to have 2 separate gents (on this forum) send me their MAP files. I ended up sticking with the newer ST4s DP map, because the other DP map had my fan running all the time (it was an S4R DP map (996 engine)).

The cables to connect to your ECU are about $30 if you go thru Lonetec.
The reading/writing SW is free -- donation accepted... It's IAWReader, IAWWriter and IAW Diag

https://www.ducati.ms/forums/241-tech-forum/687521-2003-st4s-planning-install-5am-ecu.html

Read Post #15...
Did you end up finding a ST4s DP map? I'm in need of one if you could send it. I'd super appreciate it!
...Joe
 

·
Registered
Joined
·
3,810 Posts
racerx95127 : Stelios is the gent that sent me the DP Map (bin file). Thanks again, Stelios!!! But it will only work on a 5AM ECU. If you have the older gen., ST4s, it will have a 59M, and this DP map will not work for a 59M.
 
1 - 11 of 11 Posts
Top