Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
I have a intermittent high idle problem with my Monster 1100 EVO.

The problem is intermittent, occurs just after startup, and is not temperature dependent. When malfunctioning, the idle will sit just over 3000rpm and no amount of warmup will bring it down. On other starts, it idles as it should around 1300-1500rpm.

Do the monsters (specifically the 1100 EVO's) have some sort of IAC valve like most cars and some other bikes do? If so, is it computer controlled, or vacuum controlled?

What other inputs to the ECU could cause a high idle? incorrect IAT reading? incorrect MAP reading? bad O2 sensor?

If the ECU does NOT have control over idle speed in any way shape or form, then that tells me idle issue would have to be mechanical in nature (like vacuum leak or sticking throttle cable). I'm 99% sure it's not a sticking throttle cable.

Sorry, I'm not extremely familiar with the particular hardware that this bike has (yet)...
 

·
Registered
Joined
·
1,386 Posts
Mine has no high idle at all on cold starts but it will sometimes sit at 2000rpms when I come to a stop with the clutch in... or out and in neutral, it makes no difference.

I've mentioned it to the service department at my dealer a few times but they seem clueless about my bike and why it runs the way it does.
 

·
Registered
Joined
·
48 Posts
Mine has no high idle at all on cold starts but it will sometimes sit at 2000rpms when I come to a stop with the clutch in... or out and in neutral, it makes no difference.

I've mentioned it to the service department at my dealer a few times but they seem clueless about my bike and why it runs the way it does.
Mine did the same the other day, but came right the next time I stopped. Never had anything like this happen with last bike up until I crashed it at 6,000kms. This one has now done 2,000kms.
 

·
Registered
Joined
·
77 Posts
It has happened on my 2010 hyper evo a couple of times and I was told the tps needs to be reset (why it happens I have no idea) but when it does, turn the bike off and cycle the key from 'on' to 'off' 5 times. As dumb as it sounds, it works.
 

·
Premium Member
Joined
·
176 Posts
My 2012 will sometimes idle up above 2000 rpm for 15 secs or so and then calm down. I've (perhaps in error) chalked it up to the Bazazz Z-Fi and that maybe the unit needs a little more tuning (something I haven't done because it runs so nicely now that I can live with the intermittent semi-high idle).
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #6 ·
So yeah, the issue is really more that it will sit at 2000 or just above after rolling to a stop occasionally. Most times it will sink back down to normal idle speed but sometimes it will stay up after coming to a stop. Other times, it will settle down if I flick the throttle a few times, but it is NOT the throttle cable because pressing backwards on the throttle plate actuation rod under the tank does not calm down the idle in these instances either.

FYI, I also have a bazzaz installed, but think I had seen the issue before hand. It's just more pronounced now, but have not yet gotten my fuel 100% refined yet, especially for 0% and 5% throttle positions.

I'll try the key off/on thing to reset the TPS and report back in about a week... going to be gone on vaca til then in a warm sunny place.
 

·
Registered
Joined
·
48 Posts
Taking mine into the shop tomorrow. Idle seems to a little all over the place, but feels like it's running rough in general. Wondering if it's anything to do with the Termi's and Duce.ee combined?
 

·
Registered
Joined
·
336 Posts
Taking mine into the shop tomorrow. Idle seems to a little all over the place, but feels like it's running rough in general. Wondering if it's anything to do with the Termi's and Duce.ee combined?
Good luck with that. Maybe someone will eventually get a positive solution on the idle problem. No comment on the rough running -- my bike runs great except for the inconsistent idle speed.
 
1 - 9 of 9 Posts
Top