Ducati.ms - The Ultimate Ducati Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey folks, I hope someone will know what is causing this. My 04 ST4s will not stay running sometimes at idle. I have been getting around it by nudging the cold start lever a bit when it is doing this. I have also noticed that it ONLY happens when the bike is HOT (200+ F). Things to note: I am at high altitude(6000 feet), and I recently installed K&N high flow air filter in the box. Also, fuel cap hisses vapors when the bike is hot too, open cap and fuel is boiling up bubbles. (I really hope this is normal)
 

·
Mr Leakered
Joined
·
8,831 Posts
The K&N may have leaned things out too much for the altitude. Also, you may have pinched a vent/overflow line when you lowered your tank. Be sure that they are loose enough to be wiggled with the tank down.

I have found that the vert cylinder will heat the fuel, esp after shutdown. Folks in Texas found that lining the bottom of the tank with some reflective insulation helped with this and with the feeling the hot exhaust on their legs.

You can use ducatidiag to add some fuel trim. I'd recommend a full EFI setup and TB balance to ensure things are set correctly. It's not hard to do. The desmotimes 4v manual will guide you through it.

Have a good one.
 

·
Registered
Joined
·
6 Posts
When I first got my bike it would run good unitil it warmed up then run crappy and stall out. I found a loose hose clamp on the air intake that solved the problem. Just something to look for.
 
1 - 3 of 3 Posts
Top