Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone I'm Yusuf from South Africa I recently purchased a ducati 1098s and it's a Brilliant bike I love it but today after 2 months of owning the bike I started having a problem ... so when I turn the key in the ignition I can hear the bike starting up and the lights come on ,the hooter works and basically it starts up normal but the issue I'm having is my display screen wont turn on , as I was riding to work today it started coming on and off on and off and I wasnt sure why but she rode perfect no issues the lights didnt switch of or I didnt lose any power so I know it's not the battery but the screen refuses to turn on and I cannot start her without the screen turning on for some reason , I tried to kick start in 2nd and she refuses to do that either so I am completely lost it's my 1st Ducati and I have no idea why it's doing it or what to do can anyone help with what to check or what to do please help .
 

·
Registered
Joined
·
1,354 Posts
Check the wiring first, connections at ECU and at back of display. Make sure they are clean and well-seated. When I take apart electrical connectors, I like to spray them with electrical contact cleaner which will remove oxidation. Make sure you LET IT DRY before re-seating connectors and applying power if you use any liquid-based cleaner.
 

·
Administrator
Joined
·
13,019 Posts
Hi and welcome to Ducati.ms. We are super happy to have you here.

Please fill in your location information in the UserCP Edit Your Details section, that can help if there might be someone local to you give a hand or find new friends to take a ride.
 
1 - 4 of 4 Posts
Top