Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2021 HERE!
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all,

first post here and thanks in advance for any replies!

I recently aquired a 2015 899 panigale which is my first Duc and I’ve been having nothing but problems with it. At its worst I have lost all throttle input but it started as an irregular idle. Currently the bike starts runs and rides fine below 160f engine temp but after reaching temp the idle fluctuates up and down reaching at or below 1k up to 4k when it drops low I lose all throttle input and have to cycle the key a few times before it starts back up even then it could take a couple more times to get the throttle to respond. I hooked it up to a scanner (code P0220) which indicated that there’s something going on with the vertical TPS sensor and I’m just at a loss because I’m not sure if it could be wiring or the actual sensor itself. Bike is mostly stock with the exception of the exhaust valve being removed. It did have spacers for the throttle tube but I’ve removed those.
Any help is greatly appreciated!
Love the bike when it runs properly but it’s an emotional roller coaster XD
 

·
Registered
Joined
·
33 Posts
Replace TPS sensor, spark plugs, check condition of coils. When is the last time you did any maintenance to it? Mileage? Need more info. How long have you had it?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I’ve owned the bike maybe a month so I haven’t really had any maintenance intervals pop up other than an oil change that is about due. The bike has 11k miles and change. I’ve checked the plugs and replaced coils to be safe but it is still acting up. I found a tps sensor on eBay that I’m going to order to see if that might resolve my problem. I’ll come back with the results.
 
1 - 3 of 3 Posts
Top