Ducati.ms - The Ultimate Ducati Forum banner

1 - 5 of 5 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
My wifes Monster seems to wet the plugs easily resulting in tuff or no starts without pulling plugs and cleaning.

The bike will start right away then and as long as you start and run the bike everyday or two its ok.

If it sits a few days it acts wet.

It also seems to air-bog a bit and that could be part of the problem.

Any ideas?
 

·
Premium Member
Joined
·
416 Posts
Exact same thing happened to me when I put on open exhaust cans and cut the airbox lid without re-tuning the carbs.

In my opinion, the carbs are running rich and you might need to look at carb set up or maybe put in a kit. I cleaned out my carbs and installed at Dynojet stage II kit after which the bike starts easily, idles smooth and powers thru the throttle range nicely.
 

·
Registered
Joined
·
923 Posts
+1 on the carb kit if you've changed of the intake or exhaust variables, and not the fuel mix

Otherwise, you might want to check the float and the throttle assy - make sure the bowl isn't on overflow, and nothing is staying open when it should be shut, respectively. If you're not mechanically inclined (or interested), any shop should be able to R&R it in short order
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Your probably right in reverse, I took off the open 2 Bros and put on a set of stock pipes.

The air box top is off and it has a jet kit in it.


Probably too rich and have to mess with carbs until its right.

I'm looking for a airbox lid for it if anyone has one I be glad to buy it.

Thanx for the help
 

·
Registered
Joined
·
208 Posts
i sort of have a similar problem. if i crank my bike a few timkes and let it run at idle for any lenght of time it will foul the plugs. however if i start it and go for a ride i never have a problem. it is an injected model, but i still have to choke it until it warms up. i have just been living with the problem.
 
1 - 5 of 5 Posts
Top