Ducati.ms - The Ultimate Ducati Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 2000 Ducati 750SS. I was forced to put some bad gas in it one day and as soon as it got to the lines I lost power and it developed what sounded like a click. Along with the click came a jerk. My first though was it was just the bad gas. So I switched it out and it was good for about an hour. So I started tearing it down and got to the injectors. replaced both and it started right up but now the oil pressure light came on and it still had a sputter. Now I can't seem to even get it started. Any advice would be greatly appreciated! thanks
 

·
Registered
Joined
·
724 Posts
The Fuel Filter should be replaced -- if the gas was THAT bad even more so.... Sounds like it may have had water in it???? Flush the tank and lines at the same time the fuel filter is replaced.

Hopefully the filter is just plugged and didn't allow any debris to pass into the injectors. If it did, not so sure the injectors are able to be cleaned depending on what kind of junk got in them.

I would certainly start with the filter and line flush and go from there.

Oil Pressure...... not seeing the relationship. Low idle, barely runnning at the time? Get the fuel squared away and make sure your oil level is correct. May have 2 different issues.... one at a time.... get it running but certaily don't keep running it with low oil pressure.. if that is what it is..

Good Luck :cool:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I appreciate the advice but I have to ask a really dumb question now lol.. where in the hell is the fuel filter on these things. I looked for it before but couldn't find anything that resembles a fuel filter... which line is it connected to?
 

·
Registered
Joined
·
724 Posts

Attachments

1 - 4 of 4 Posts
Top