Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
I have a '99 ST2. Anybody have any problems with fuel gauge and/or sensor in tank. Mine worked fine then slowly went from intermittent to not working. Is my sensor in the tank bad or is there a common problem with this. Thanks for any help.

Brett
 

·
Registered
Joined
·
4,019 Posts
Need more info...like is it just the "low-light" that's intermittent? Or the LCD gauge that was getting flakey?

I can guess that it's the sender in the tank. Haven't had any problems w/ my 1998 ST2... 26K miles.
 
G

·
Discussion Starter · #3 ·
fuel gauge

The bars on the fuel gauge started going intermittent,all over the place even with a full tank.Replaced the fuel filter so I could also check the connection to the sensor in the tank.Seems to be no problems.Now it pretty much just stopped working.Just curios if it is common or not.New sensor is about $150.No other problems,runs great.
 

·
Registered
Joined
·
4,019 Posts
Sounds like the sender. Although it could be the wires leading from the tank to the LCD info display. You'd have to test the wires for continuity. Maybe the connector under the LCD unit? I bet water could get in there...(haven't even seen mine, just an assumption).

I'm in the habit of zeroing my trip odometer, and head for a fill when it hits 150 or towards 200, depending on the season (low economy in cold weather, and better eco with "highway" miles).
 
G

·
Discussion Starter · #5 ·
My LCD is acting up not really the fuel sensor it keeps cuttin in and out. Any one have any ideas? '99ST2
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top