Ducati.ms - The Ultimate Ducati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi All,
I am having an annoying problem with my 2007 ST3s, on cold start the front cylinder won't fire the after a few minutes or a 500 mt ride it coffs and splutters then runs perfectly, I can smell fuel out the exhaust, so not sure if it is flooding, anyone have any ideas?
 

·
Registered
Joined
·
4,668 Posts
I hate intermittent electrical problems.

Time to get the multimeter out and start working backwards from the spark plugs...
.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Have you checked for spark at the plug when cold?
Yes the plug when cold is fine I even put new plugs in to see if it would make a difference, but it didn't, once it is warmed up there is no isssue, I was thinking there might be something wrong with the auto choke, but this is electronically managed?
 

·
Registered
Joined
·
317 Posts
Well if it has spark that leaves fuel and compression. The next thing I would check is if the injector is working when cold. Few ways to check, 1 feel/listen for a clicking sound, 2 remove air filter and using light look for fuel spraying, 3 remove plug and see if it's wet.
 

·
Registered
Joined
·
154 Posts
Does the ST3 have coil overs? If it doesn't, this probably won't apply.

If so, I've just spent a couple of months chasing a similar fault in a 999, and I put up a post about my fck ups, I mean, process, headed "finally" in the superbikes forum. They will probably have similiar ecu, so it may help. (finally.727808/#post-7046236).

The issue was the 3 pin plug on the coil over is a different brand to the rest of the bike, and there was only about half a millimeter, when pushing the plug together, from the point of contact to the fully home position. There really should be at least a couple millimetres of contact overlap. And, being on the front cylinder, is more exposed to the elements. In my case the intermittant ignition fault caused the ecu to cut injector signal, but no ignition fault was reported by the ecu.
 
1 - 8 of 8 Posts
Top