Ducati.ms - The Ultimate Ducati Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Here I was, happily riding to work, minding my own business and looked down at the speedo, and found I couldn't see it. There was that much smoke pouring out from the heatsink and snap, crackle and pop at the reg/ rec. Yanked the pos lead of the battery to stop the total meltdown and possible fire...
Then push it back home 8kms to get the car and go to work- for a 12 hour shift.....
OK the batt light would stay on from time to time in the past up to 2000rpm, but not all the time. Charge rate was fine at this time and was told that the reg/rec does make the the battery light go on, on mid 90's Duc's with no affect to battery charge just get a spare incase..
If I replace the reg/ rec and check the stator the wiring, maybe beef it up, would this fix it, or is there something more sinister going on???
 

·
Registered
Joined
·
100 Posts
Discussion Starter #2
600ss=900ss??

Looking at new aftermarket reg/ rec.....are the 900SS reg/ rec the same as the 600/ monster etc?
I noticed the alternator for the 600750 puts out 300w and the 900 puts out 350w- does it matter as far as the reg/ recs' concerned??
 

·
Banned
Joined
·
2,916 Posts
i don't think so, only difference between them all should
be that they are either 2 or 3 phase ( yellow cables ) rec-
tifiers.

cheers.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #4
Looking at a new Electrosport R 510 For US$135 (AU$147). Seems the go. I can't find any bared or crimped wiring, so I'm concerned with hooking up a newy- Do these things normally just spontaneously combust??
 

·
Banned
Joined
·
2,916 Posts
i read in one of shazaam's posts here, that a semi blocked fuel filter
can cause the regulator to fry i.e., it is generally a good idea, to have all
the connections cleaned with some contact cleaner.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #7
Cheers, and thanks for your help guys. Will clean all contacts I can and for extra insurance, check the fuel filter(I assume extra current draw from trying to pump through a blockage, putting more pressure on the pump?). Will get the reg, and if fine, will get back and let you know(if I can actually get off the Duc for more than 5 minutes, lol).
 

·
Registered
Joined
·
1,278 Posts
The usual fault with the units are poor grounding of the case and loose connections at the yellow leads from the alternator.The stock bullet style connectors on the alt. leads loosen up and it creates a high resistance and enough heat to let the magic smoke out of the wires.Many people have soldered the wires together and eliminated the connectors or used splice connectors that screw together tightly.Many shops that do trailer wiring have suitable connectors available.Be sure the case of the reg. is well grounded to the frame.There should be a black wire with a star washer on one of the reg. attachment bolts to provide the ground as the wellnuts the reg. is mounted with are made of rubber.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #9
Update! Electrosport reg/rec..

Well, Put the reg/rec in and has been running well ever since,
No dramas whatso ever.
Electrosport ESR510 works well for a 600SS- for less than AU$200 compared to the extortionate price of genuine Ducati...:)
 
1 - 10 of 10 Posts
Top