Ducati.ms - The Ultimate Ducati Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
I was going to install an Evoluzione clutch slave that I got from Mark over at wounded Duc but there seems to be some parts missing (Bearing and rubber seals). I emailed him and I am sure he will make it right, but I have a question about the install. The stock part seems to have a lip that extends past the flange of slave and creates a tight fit to the engine case. The Evoluzione is just machined flat. I assume the rubber seals and the bearing take up the difference in space? Thanks in advance.

I was lucky that I previously ordered an upgraded piston and I was able to install that into the original clutch slave and get the bike going for a quick ride. I could not believe how messed up the stock piston was. All gooked up and leaking all over. The tip from Deadguy and several other members worked like a charm! Just crack open the top banjo bolt and let out the air!
 

·
Registered
Joined
·
139 Posts
I was going to install an Evoluzione clutch slave that I got from Mark over at wounded Duc but there seems to be some parts missing (Bearing and rubber seals). I emailed him and I am sure he will make it right, but I have a question about the install. The stock part seems to have a lip that extends past the flange of slave and creates a tight fit to the engine case. The Evoluzione is just machined flat. I assume the rubber seals and the bearing take up the difference in space? Thanks in advance.

I was lucky that I previously ordered an upgraded piston and I was able to install that into the original clutch slave and get the bike going for a quick ride. I could not believe how messed up the stock piston was. All gooked up and leaking all over. The tip from Deadguy and several other members worked like a charm! Just crack open the top banjo bolt and let out the air!
Yes, it sounds like there are a couple missing parts. I got mine from LT and it came in a little foam block that had a bit in each recessed portion (of said foam block). Don't worry about the machined bottom, it seals just fine. Just follow the included install instructions and you should be good.

Cheers,
C
 

·
Registered
Joined
·
207 Posts
Discussion Starter #3
CFury:

Thanks for the reply. I found the instructions online and realized the two rubber seals missing and also the I was trying to put the anodized cover on backwards! I got the part used from Mark over at Wounded Duc and once we figured out what was missing he paid for NEW parts from Evoluzione. Great customer service especially on a used clutch slave. The Evo slave is beautifully machined, I'll probably throw on a braided stainless clutch line too.
 
1 - 3 of 3 Posts
Top