Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I need some help with my project
It´s a 999 -04 that I blow the Engine last year.
So now It´s carrying a 1198 Diavel engine instead, mostly because I came over it at a fair price.
I have replaced pretty much Everything to 1198 stuff, loom, dash. ECU, injection and left/right handlebar.
The thing is that I can not even make the Engine turn arund when I press the start button. The fuelpump starts but nothing else happens.
I have one error that appears in the dash and It is DTC 8.0 but there is no tractioncontrol in this bike and the ECU is 1198, not S. Anyway the Engine should turn around is my thinking?
The Immo is deactivated also but I still have that error in my dash, could that be the problem?

Hoping for advice...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
no key, this is a trackbike only.
Thats the reason the Immo is deactivated.
I have a key elliminator from woodcraft instead of the key and antenna.
 

·
Registered
Joined
·
3,543 Posts
put all the 999 stuff back in and have the ecu mapped to suit the 11 degree 1200 engine. or just multiply the 999 fuel map by 1.2 or so.
 

·
Premium Member
Joined
·
5,151 Posts
Get a wiring diagram and go through the starter diagram. It could be something as simple as the starter relay to a faulty start button. Check the easy stuff first.

Brad. Been down the road of getting a 999 ecu re-flashed to1198. Problem at the time was not being able to lift the fuel and ignition map tables from the tc shit mixed in to those tables. Maybe I was doing something wrong but the 999 ecu couldn’t read the 1198 tables and it ran like poo. Even rexa couldn’t do it. Maybe things have changed over the last 6 years. Ended up using a microtec which is just a joy to use.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Get a wiring diagram and go through the starter diagram. It could be something as simple as the starter relay to a faulty start button. Check the easy stuff first.

Brad. Been down the road of getting a 999 ecu re-flashed to1198. Problem at the time was not being able to lift the fuel and ignition map tables from the tc shit mixed in to those tables. Maybe I was doing something wrong but the 999 ecu couldn’t read the 1198 tables and it ran like poo. Even rexa couldn’t do it. Maybe things have changed over the last 6 years. Ended up using a microtec which is just a joy to use.
I'm on to it tomorrow, was thinking like you write that it might be a easy fix. Feedback and tips Before I start is allways helpful :)
One thing I've notist when I compare 1198 and 1198S wiring is that they are very diffrent therefore the question about the ECU:s Im not sure mine is a 1198...If I read the wiring correctly. The wiring is 1198 that I'm sure of.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Yeah the neutralswitch is under control.
I’ve been on to the problem today and now I’m sure of the ECU, it’s a 1198S, was’nt so difficult to figure it out if you look att the dash 🙈...
The loom on the other hand is more of a mystery yet.
I have wiringdiagram for both 1198 and S but the resolution in the 1198 sucks I can’t see a shit. The 1198S is no problem.
It might be 1098 I’m not sure anymore. My loom is not 1198S that I know...
 

·
Registered
Joined
·
281 Posts
Check this:

I think it is also possible to connect your starter button straight to starter solenoid. But of course you need to identify your loom first, what model it is. There isn't any part number in loom left?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
The loom is identyfied, It’s 1098
I’ve switched the cabels in the loom just to ser if that part works and it does but since I have a 1198S ECU it’s more things that isn’t the same so, off with the 1098 loom and on with a 1198S...
I’ll update when it arrives.
 
1 - 14 of 14 Posts
Top