Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello all,
I'm a jerk which has the good idea of removing my dashboard in order to change it for a smaller one and change the look my bike… a 800S2R.
After multiples adventures, I tried to change my .bin file into one without the immobilizer, using the .xdf coming from there :

(MM 5AMHW610) Ducati S2R800 / MTS1100 | Motorcycle Tuning XDF Wiki | Fandom powered by Wikia

First I saved my .bin file and then change the setting of the “Immobilizer (likely!)” flag from unset to set.
Then I upload it to the bike and try to start…without luck.
The default "U1600 immobilizer" is still there and prevents me from starting the bike.
I’m lost for a couple of reasons :
• I have 2 lambdas on and off on tunerpro but only one was present on the bike (mine was removed previously)
• The “address” (?) 4D144 is both related to the immobilizer and lambda 1 ??

I plug back the dashboard antenna and so on, the starter is craking ?

Is there anyway anybody can help me out ?

I’m fu*£ing stuck and I have no idea upon how to fix it…is the .xdf not right ? Is there anything else that might be wrong ?

Thanks for any assistance you can provide, that would be awesome
 

·
Registered
Joined
·
463 Posts
What year and model is your S2R?

never mind, just noticed it is a 800S2R. ^^
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Hello Dutch,

Thanks for having a look, I'm struggling...
The 800S2R is a 2006 "regular" European model, with the catalyzer removed.

Right now my point is :

Using the xdf from there :
www.von-der-salierburg.de/download/GuzziDiag/xdf/5AM_Ducati_S2_800R_V1.28.zip

the lambda's flags when set or unset are changing the addresses :
lambda 1 = 4D144
lambda 2 = 4D145

using the .xdf from there :
(MM 5AMHW610) Ducati S2R800 / MTS1100 | Motorcycle Tuning XDF Wiki | Fandom powered by Wikia

lambda 1 AND immo flag = 4D144 --> when I set the immo flag it changes as well the tick box of lambda 1...
lambda 2 = 4D145

On none of them I have an "item" at adress 4D146 ?

Is it possible that the address of the immo is actually not the 4D144 ?

Because with the dashboard and the key close to the antenna, the starer relay "clicks" (with the modified or unmodified file), but when I unplug the dashboard, with the modified file, then I have the U1600 default "immobilizer".

You'll find enclosed the xdf, original .bin and modified .bin files + pictures of the ECU (?)

I'll stick around my screen, thanks for the help
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter #6 (Edited)
Currently, on the original I have 00110010 .... hum, should I change a byte ? Does it look like an immo adress better than the previous 4D144 ?
It corresponds to an "unknown table 1" (in the "developpment" part).
 

·
Registered
Joined
·
93 Posts
Hello kartoon,
change Adress 4D0CE from "01" to "00", disconnect the antenna and you should be ready to start.
Regards
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Thanks a lot dutch and idaka,

I'm in contact with Pauldaytona and he was faster, I just tried the address 4D0CE and it worked !
At least the starter relay, now I got to reassemble all the rest of the wiring !

I have a question, how do "read" or understand all these address and found the needle in allllll that datas ? Is there a software or something ?
I'm curious ?

Anyway thnak you very much, and hope these thread may help somebody else !
 

·
Registered
Joined
·
52 Posts
Kartoon, where did you find address 4D0CE ?

I can see 4D144 & 4D145 in lambda 1&2

Just in case I need to turn mine off on MTS1100...


Thanks.
 

·
Registered
Joined
·
93 Posts
Hello, UKSteve,
unfortunately the adresses are different between the Ducati Models.
For your MTS1100 the correct adress to switch Immo off is 4D144.

If you want to switch immo off, open the bin-file with a Hex-Editor (for example Hex Edit) and change the content of adress 4D144 from 01 to 00.
You can also use the hex-editor,which is included in TunerPro.

I think,the xdf which Kartoon mentioned has some failures, if you use it fpr MTS1100

Regards
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
Yes, in fact the .xdf was not applicable to my bike and I must have use a S4 one !!
No idea upon how at the end you can find out the relevance of the xdf regarding the information in the .bin file, its far above my level.

My bike as started and I only need to fix a couples of wires to the frame to ride...can't wait for it.

cheers
 

·
Registered
Joined
·
6 Posts
Hey all, sorry for resurrecting an older thread, but I'm also in the same boat. I've got an '05 S2R 800 (US model) and set 4D0CE to '0' using a hex editor on the binary. Re-flashed successfully but immobilizer is still functioning. I also checked 4D144 against the XDF that I found somewhere and it's already "unset" comparing what TunerPro does to what I downloaded off the bike. Any idea if there is a difference with my model? If so, does anyone know what the proper address is?

Here is the info on the ECU:

Drawing: 2218B18DZ12
Hardware: IAW5AMHW610
Omologation:
Software:
Tester: DUC
Date: 2005.02.28



Thanks for any help!
 

·
Registered
Joined
·
6 Posts
Update: Ended up using TuneECU with an old android tablet. Had the immobilizer deleted in less then 20 mins (15 mins to pull down map, 10 seconds to uncheck immobilizer in the maps parameters). Too easy. Now off to deciding on Koso DB02 or RX2N and wiring...
 
1 - 15 of 15 Posts
Top