Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Hello,

This problem recently arose on my SF 1098 a few days ago.

The motorbike started having problems dropping in RPMs when letting off the throttle going to a stop (I’ve made sure the throttle cable was good). During decelerating the RPMs will drop down however there’s this clicking noise that happens for like 1-2 seconds then the rpms drop down back to idle.

Can anyone give me some insight please. Thank you !
 

·
Bon Vivant
Joined
·
11,424 Posts
Its been about 10 years since I've pulled my SF apart but if I recall the cables go to a TPS and the throttle bodies are electronically controlled by the ECU, perhaps there is a mechanical or software fault in the system there. I'd recommend you take it to a dealer.
 

·
Registered
Joined
·
3,395 Posts
The throttle body and butterflies are controlled directly by a cable. No ride by wire junk on the first SFS. I would check for a vacuum leak.
IMG_0739.jpg



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3,395 Posts
Flynbulldog, you always have good information to share. When you have a huge bank of knowledge it's impossible to remember everything. I know I sure can't remember everything.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,082 Posts
There's a small stepper motor on the throttle body assembly for the idle control valve. This part being faulty could explain your erratic idle behavior.
 

·
Registered
Joined
·
1,272 Posts
The stepper motor has vacuum hoses that could possibly be bad/off.
 
1 - 7 of 7 Posts
Top