Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Hey,
I have a 2013 Ducati 1199 Panigale and I am having a problem with the fan not working. One of the prior owner sent the ecu out to have some changes done it like side bypass for track days, i have also notice the fan comes on at much lower temp 200 and shuts off at 183. The problem i am having is that the fan seems to work for 2 or 3 times before i get a warning on the dash that it not working at all. If i pull out the ignition relay and put it back the fan will work again for another time or 2 then faults out again. I have check the fan and it works fine, also I have check the wiring harness running back to bbs unit for any broken wires or pinched or melted ones and found nothing. So I'm kinda stuck at the moment, any help would be great, thanks
 

·
Registered
Joined
·
337 Posts
Whenever the fan doesn't come on when it should, check the voltage to the fan. If it's getting power but not coming on, the fan motor may be going bad.

I will say I've had flashes done on Panigales where the fans were turned off for some reason. However, I've never seen one that turned the fan on sometimes and not others. So I'd be surprised if the issue were ECU related.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
After taking the fan out and bench testing it by running 12 volt power directly to it, I found that after a few minutes of the fan running the back of the fan where is the motor is was starting to get really hot, like you can't touch it with your finger without burning them, so i figure that the fan motor is drawing to much power causing it to fault out on the bike after it warms up. I ordered a used fan off ebay and installed it and the bike is working fine now, no more fan faults, yahoo!!!!
 
1 - 3 of 3 Posts
Top