Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Hey everyone, haven't been on here in a LONG time as I've been off my Duc for quite some time. However, turning it back on after recently rebuilding the motor has yielded this new weirdness from the dash. I've been told its the old Christmas Tree of death which indicates a bad dash. However, I'm not convinced as the error displayed sort of lends itself to is the dash not seeing a connected ECU. In fact, if you disconnect the ECU, it's the same exact error. Checked all wiring, ground points, fuses, tried a second battery, and verified good voltage at the dedicated ECU 5A fuse terminal. The bike worked perfectly before I had to rebuild it due to a blown bottom end bearing.

I believe someone has had that issue here before but that person didn't say what it was and doesn't look to be active.

"Load SBK Che 005" is what the dash says on my old 1098.

Any ideas??

Reference video of that person which basically is the same exact thing that happens to my bike.

 

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
For anyone interested or if this happens to them in the future, per Chad at SOS Diagnostics, the dashboard was bad. He could not repair it so he provided me a replacement unit and was able to copy my old data over. Bike is working fine now.
 
1 - 3 of 3 Posts
Top