Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
440 Posts
Discussion Starter · #1 ·
This one is a weird one to me. Washed the Hyper (08 1100s) thisd weekend and used some generic engine degreaser on the motor because it had some oil from the leaky valve cover on the horizontal cylinder.

Rinsed it real good with a garden hose. Fired up the bike and it ran just fine. Pushed it back into the garage.

Fast forward to today. Fire it up to ride it to work. Pull in the clutch , shift into first and it lurches forward and dies....all with the clutch pulled in. The clutch is obviously not disengaging. Found neutral and pushed it into the garage.

What gives ? Contaminated clutch fluid ? Clutch pack not getting along with the degreaser ? It has a semi open cover ....I drilled a bunch of holes in it because I am cheap AF. I have ridden it through the rain for hours....can't believe a little garden hose action would have any effect on it.

I will see if it has magically fixed itself when I get home.
 

·
Registered
Joined
·
887 Posts
Metallic/sintered friction material on clutch plates left in contact with (wet) steel clutch plates can rust and bind together. Put the bike in gear, pull in the clutch lever and rock the bike front-to-back to break them free.
 

·
Registered
Joined
·
440 Posts
Discussion Starter · #3 ·
fired up the bike when I got home , worked the clutch lever until it started rattling real nice in the clutch area. All is well. I figure the degreaser/water gunked it up a little. If only all fixes were this easy !!!
 

·
Registered
Joined
·
440 Posts
Discussion Starter · #5 ·
A good dragstrip style launch will clean the plates up nicely, too. Dry clutches love abuse. I'm serious.
Then this thing loves me !!! :grin2:

Dragstrip style launches are fun and save front tire wear !!!
 

·
Registered
Joined
·
166 Posts
Yup, just a little rust sticking the plates together. Nothing a good ride won’t fix :)


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top